summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Gamble2019-11-17 13:23:18 +1100
committerMatthew Gamble2019-11-17 13:23:18 +1100
commit5c29df7a71f86dc075336575531901a7a64fb23a (patch)
tree0cbedec470cc4653d9ac181f306b048b89adc0f3
parent5490d29c0dd28edd23b47215a91b28e4c42a08aa (diff)
downloadaur-5c29df7a71f86dc075336575531901a7a64fb23a.tar.gz
Update to latest version
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD8
-rw-r--r--config.example.json8
-rw-r--r--uwsgi.py7
4 files changed, 16 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b58dd8ce1803..780afec95b5e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Sat Jan 5 09:40:03 UTC 2019
pkgbase = python-wsgidav
pkgdesc = Generic WebDAV server based on WSGI
- pkgver = 2.4.1
- pkgrel = 4
+ pkgver = 3.0.1
+ pkgrel = 1
url = https://github.com/mar10/wsgidav
arch = any
license = MIT
@@ -15,12 +13,12 @@ pkgbase = python-wsgidav
depends = python-jsmin
optdepends = python-lxml: for faster XML processing
optdepends = python-cheroot: to use the built-in webserver
- source = https://files.pythonhosted.org/packages/07/06/8952c1496a68db8d7571bfa4ddfbf0bcb0d155d23e64e3909752b9c6acfc/WsgiDAV-2.4.1.tar.gz
- source = https://raw.githubusercontent.com/mar10/wsgidav/v2.4.1/LICENSE
+ source = https://files.pythonhosted.org/packages/17/c4/360564dac7ad8f0a13914436b011dc520e898608cd80179b074ad6a27a0c/WsgiDAV-3.0.1.tar.gz
+ source = https://raw.githubusercontent.com/mar10/wsgidav/v3.0.1/LICENSE
source = uwsgi.py
source = uwsgi.ini
source = config.example.json
- sha256sums = d95014d71f595ae08062cb8608742adb4c1d7aece029e22ebe7de010359cb8f5
+ sha256sums = 415ac221806a266a3661f6f2f91ecc8dbcbe3653cdb1508abc0c397ea0cf35f3
sha256sums = efab1ba243ab3de9a6fb75068eb39424055408849aa3aabf085f0fca0a1be3d1
sha256sums = 7ca04465a67ec0726a4503aea86695e6d1948fa233dd2caa0fcee4db779aeaaf
sha256sums = 25826e3ceec2e9e01c54e6367966537017b0c758c7eda131566a95f97b474250
diff --git a/PKGBUILD b/PKGBUILD
index a8d2eda64f91..f83f0150868a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Matthew Gamble <git@matthewgamble.net>
pkgname=python-wsgidav
-pkgver=2.4.1
-pkgrel=4
+pkgver=3.0.1
+pkgrel=1
pkgdesc="Generic WebDAV server based on WSGI"
arch=("any")
license=("MIT")
@@ -14,14 +14,14 @@ optdepends=(
"python-cheroot: to use the built-in webserver"
)
source=(
- "https://files.pythonhosted.org/packages/07/06/8952c1496a68db8d7571bfa4ddfbf0bcb0d155d23e64e3909752b9c6acfc/WsgiDAV-${pkgver}.tar.gz"
+ "https://files.pythonhosted.org/packages/17/c4/360564dac7ad8f0a13914436b011dc520e898608cd80179b074ad6a27a0c/WsgiDAV-3.0.1.tar.gz"
"https://raw.githubusercontent.com/mar10/wsgidav/v${pkgver}/LICENSE"
"uwsgi.py"
"uwsgi.ini"
"config.example.json"
)
sha256sums=(
- "d95014d71f595ae08062cb8608742adb4c1d7aece029e22ebe7de010359cb8f5"
+ "415ac221806a266a3661f6f2f91ecc8dbcbe3653cdb1508abc0c397ea0cf35f3"
"efab1ba243ab3de9a6fb75068eb39424055408849aa3aabf085f0fca0a1be3d1"
"7ca04465a67ec0726a4503aea86695e6d1948fa233dd2caa0fcee4db779aeaaf"
"25826e3ceec2e9e01c54e6367966537017b0c758c7eda131566a95f97b474250"
diff --git a/config.example.json b/config.example.json
index 2a0e420a120d..5836ec6615ac 100644
--- a/config.example.json
+++ b/config.example.json
@@ -2,9 +2,11 @@
"host": "files.example.com",
"mount_path": "/webdav",
"provider_mapping": {"/myfiles": "/path/to/files"},
- "user_mapping": {
- "/myfiles": {
- "myuser": {"password": "mypassword", "description": "", "roles": []}
+ "simple_dc": {
+ "user_mapping": {
+ "/myfiles": {
+ "myuser": {"password": "mypassword", "description": "", "roles": []}
+ }
}
},
"verbose": 1
diff --git a/uwsgi.py b/uwsgi.py
index 0c11f7ccf66d..a389f4a94e8e 100644
--- a/uwsgi.py
+++ b/uwsgi.py
@@ -1,11 +1,8 @@
import json
import os
-from wsgidav.wsgidav_app import DEFAULT_CONFIG, WsgiDAVApp
+from wsgidav.wsgidav_app import WsgiDAVApp
with open(os.environ.get("WSGIDAV_CONFIG_FILE", "/etc/wsgidav/config.json"), mode="r", encoding="utf-8") as json_file:
json_config = json.load(json_file)
-config = DEFAULT_CONFIG.copy()
-config.update(json_config)
-
-app = WsgiDAVApp(config)
+app = WsgiDAVApp(json_config)