summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Gamble2022-01-23 20:51:39 +1100
committerMatthew Gamble2022-01-23 20:51:39 +1100
commitdc83ca9bfe1291ecf6be325c5ac10d81c2a481ee (patch)
tree2b54c9780290be03aa90a3b2f748a7e040e00683
parentf1089dca96c72cf0562ca25edc04b987e85eacfe (diff)
downloadaur-dc83ca9bfe1291ecf6be325c5ac10d81c2a481ee.tar.gz
Update to latest release - v4.0.1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD9
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e4464b8c3d50..ef653d07d89b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,26 @@
pkgbase = python-wsgidav
pkgdesc = Generic WebDAV server based on WSGI
- pkgver = 3.1.1
+ pkgver = 4.0.1
pkgrel = 1
url = https://github.com/mar10/wsgidav
arch = any
license = MIT
makedepends = python-setuptools
depends = python
- depends = python-defusedxml
depends = python-setuptools
+ depends = python-defusedxml
depends = python-yaml
depends = python-json5
depends = python-jinja
- depends = python-six
optdepends = python-lxml: for faster XML processing
optdepends = python-cheroot: to use the built-in webserver
- source = https://pypi.io/packages/source/W/WsgiDAV/WsgiDAV-3.1.1.tar.gz
+ optdepends = python-pam: to use PAM for authentication
+ source = https://pypi.io/packages/source/W/WsgiDAV/WsgiDAV-4.0.1.tar.gz
source = uwsgi.py
source = uwsgi.ini
source = config.example.json
source = config.example.json5
- sha256sums = e6bdc5af7a4c92f1acb2ac20f272badf4a0b934cf4b951532ea907b00f38ad0d
+ sha256sums = 7b28e3e7e604c5665e7e1b1188a8d39d6ee60e635297293d3a175798ba24eccd
sha256sums = 774ee839b5248d2614294daf2c8a28fda69f1524d8b5b61d9e75de7b9c986b4d
sha256sums = 25826e3ceec2e9e01c54e6367966537017b0c758c7eda131566a95f97b474250
sha256sums = 9e4d7e9ae9e56a5d0f14c91b296825114e57456888280e59dcf158dad36b9474
diff --git a/PKGBUILD b/PKGBUILD
index 4e2650882bac..b9b0c398a05d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,18 @@
# Maintainer: Matthew Gamble <git@matthewgamble.net>
pkgname=python-wsgidav
-pkgver=3.1.1
+pkgver=4.0.1
pkgrel=1
pkgdesc="Generic WebDAV server based on WSGI"
arch=("any")
license=("MIT")
url="https://github.com/mar10/wsgidav"
-depends=("python" "python-defusedxml" "python-setuptools" "python-yaml" "python-json5" "python-jinja" "python-six")
+depends=("python" "python-setuptools" "python-defusedxml" "python-yaml" "python-json5" "python-jinja")
makedepends=("python-setuptools")
optdepends=(
"python-lxml: for faster XML processing"
"python-cheroot: to use the built-in webserver"
+ "python-pam: to use PAM for authentication"
)
source=(
"https://pypi.io/packages/source/W/WsgiDAV/WsgiDAV-${pkgver}.tar.gz"
@@ -21,7 +22,7 @@ source=(
"config.example.json5"
)
sha256sums=(
- "e6bdc5af7a4c92f1acb2ac20f272badf4a0b934cf4b951532ea907b00f38ad0d"
+ "7b28e3e7e604c5665e7e1b1188a8d39d6ee60e635297293d3a175798ba24eccd"
"774ee839b5248d2614294daf2c8a28fda69f1524d8b5b61d9e75de7b9c986b4d"
"25826e3ceec2e9e01c54e6367966537017b0c758c7eda131566a95f97b474250"
"9e4d7e9ae9e56a5d0f14c91b296825114e57456888280e59dcf158dad36b9474"
@@ -46,4 +47,6 @@ package() {
install -Dm644 "${srcdir}/uwsgi.ini" "${pkgdir}/usr/share/python-wsgidav/uwsgi.ini"
install -Dm644 "${srcdir}/config.example.json" "${pkgdir}/usr/share/python-wsgidav/config.example.json"
install -Dm644 "${srcdir}/config.example.json5" "${pkgdir}/usr/share/python-wsgidav/config.example.json5"
+ # Waiting on this issue to be resolved: https://github.com/mar10/wsgidav/issues/247
+ #install -Dm644 "sample_wsgidav.yaml" "${pkgdir}/usr/share/python-wsgidav/config.example.yaml"
}