summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2021-12-15 09:52:29 -0500
committerGuillaume Horel2021-12-15 09:52:29 -0500
commitb35a197227fdb8cafdb9174350d0ade70a1e0a3b (patch)
tree6a40a948d1ecf96e3afcaa8d1ade2ec5cc2eaf6a
parent29c4d3e09543f0f5eafb7fba0ea9cf6d40007a62 (diff)
downloadaur-b35a197227fdb8cafdb9174350d0ade70a1e0a3b.tar.gz
bump to 0.10.5
-rw-r--r--PKGBUILD10
1 files changed, 4 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index afc856b09b18..886ea13a3ea9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,26 @@
# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
pkgname=python-wtforms-components
_pkgname=wtforms-components
-pkgver=0.10.4
+pkgver=0.10.5
pkgrel=1
pkgdesc='Additional fields, validators and widgets for WTForms'
arch=('any')
url="https://wtforms-components.readthedocs.io"
license=('BSD')
depends=('python-colour' 'python-dateutil' 'python-infinity' 'python-intervals' 'python-validators')
-checkdepends=('python-pytest' 'python-wtforms-test')
+checkdepends=('python-pytest' 'python-wtforms-test' 'python-email-validator')
source=("$pkgname-$pkgver.tar.gz::https://github.com/kvesteri/wtforms-components/archive/$pkgver.tar.gz")
-sha256sums=('fab1b0e4e28ca214e353942de944b0b43132dff10f888e2546531817c52b5909')
+sha256sums=('aa8bec34effc28db0e4a187499f56f85c5bd5b3969342451da84ebc2a3d7c3cd')
build() {
cd "$srcdir/${_pkgname}-${pkgver}"
-
python setup.py build
}
package() {
cd "$srcdir/${_pkgname}-${pkgver}"
-
- python setup.py install --root="${pkgdir}" --optimize=1
+ python setup.py install --root="${pkgdir}" --skip-build --optimize=1
install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}