summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlphaJack2024-02-09 12:37:42 +0100
committerAlphaJack2024-02-09 12:37:42 +0100
commitac659d08447decfb3363c2240e5bd2cab4c36840 (patch)
tree13c3eae2480a9a4bd271ce7a40be7c1feb9ea140
downloadaur-ac659d08447decfb3363c2240e5bd2cab4c36840.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e31d68643cd5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-wtforms-json
+ pkgdesc = Adds smart json support for WTForms. Useful for when using WTForms with RESTful APIs
+ pkgver = 0.3.5
+ pkgrel = 1
+ url = https://github.com/kvesteri/wtforms-json
+ arch = any
+ license = custom
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-setuptools
+ makedepends = python-wheel
+ options = !strip
+ source = https://pypi.org/packages/source/W/WTForms-JSON/WTForms-JSON-0.3.5.tar.gz
+ b2sums = 816fc6928045c8d8c4b59cee4e667f7fca0834804fc03b8f1c40af5dcfff6897d31aaeb6d878bcef5032172b8905b5affafccc0d4a0d3a9bc255270ca374ef8e
+
+pkgname = python-wtforms-json
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..12cb0e2bde6e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: AlphaJack <alphajack at tuta dot io>
+
+pkgname="python-wtforms-json"
+_name="WTForms-JSON"
+pkgver=0.3.5
+pkgrel=1
+pkgdesc="Adds smart json support for WTForms. Useful for when using WTForms with RESTful APIs"
+arch=(any)
+url="https://github.com/kvesteri/wtforms-json"
+license=('custom')
+makedepends=("python-build" "python-installer" "python-setuptools" "python-wheel")
+source=("https://pypi.org/packages/source/${_name:0:1}/$_name/$_name-$pkgver.tar.gz")
+b2sums=('816fc6928045c8d8c4b59cee4e667f7fca0834804fc03b8f1c40af5dcfff6897d31aaeb6d878bcef5032172b8905b5affafccc0d4a0d3a9bc255270ca374ef8e')
+options=("!strip")
+
+build(){
+ cd "$_name-$pkgver"
+ python -m build --wheel --no-isolation
+}
+
+package(){
+ cd "$_name-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -D -m 644 "LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname"
+}