summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordobedobedo2022-07-24 10:32:29 +0300
committerdobedobedo2022-07-24 10:32:29 +0300
commit1cde028c6dd2b65cb45f162a4e45fe1d6b879c69 (patch)
tree6dedff58b6c022e7a3c7a08b95f24eb57c35e754
parentbacefd33eb05c1075a96020868d2b79b81ebc56c (diff)
downloadaur-1cde028c6dd2b65cb45f162a4e45fe1d6b879c69.tar.gz
Use built-in WxWidgets files
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD23
2 files changed, 6 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8ef7dfe7d5ba..cd6f01734dbb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-wxpython-dev
pkgdesc = Cross-platform GUI toolkit. Developer version
pkgver = 4.2.0a1.dev5449+3ac1e526
- pkgrel = 1
+ pkgrel = 2
url = https://www.wxpython.org
arch = x86_64
license = custom:wxWindows
@@ -13,9 +13,6 @@ pkgbase = python-wxpython-dev
makedepends = webkit2gtk
makedepends = python-requests
makedepends = python-setuptools
- makedepends = sip
- makedepends = doxygen
- makedepends = waf
makedepends = python-attrdict
depends = wxwidgets-gtk3
depends = python-six
@@ -23,8 +20,6 @@ pkgbase = python-wxpython-dev
provides = python-wxpython
conflicts = python-wxpython
source = https://wxpython.org/Phoenix/snapshot-builds/wxPython-4.2.0a1.dev5449+3ac1e526.tar.gz
- source = https://github.com/wxWidgets/wxWidgets/releases/download/v3.2.0/wxWidgets-3.2.0.tar.bz2
sha512sums = f7fe342c70fd8fa66de67e1aeeb00290dbe2f995a4917a7bb7000d025cf5a084199bb1db6f23bc7b743448aa185f725af57aa9ed2b2ae8eead08ca69bb8e4137
- sha512sums = e55e7c5ac7abcacf2ecff7c22e367db17ff5a077d3d5d2aa7589e8ba7cc6695cfa48c0f00bcfdffeda8dc4f974f97a857fb61b4b300a724f7687d710fbb23967
pkgname = python-wxpython-dev
diff --git a/PKGBUILD b/PKGBUILD
index b1d4825143f1..51a1c6f706f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,36 +7,23 @@
pkgname=python-wxpython-dev
_pkgname=wxPython
pkgver=4.2.0a1.dev5449+3ac1e526
-pkgrel=1
-_wxver=3.2.0
+pkgrel=2
pkgdesc='Cross-platform GUI toolkit. Developer version'
arch=('x86_64')
license=('custom:wxWindows')
url='https://www.wxpython.org'
depends=('wxwidgets-gtk3' 'python-six')
optdepends=('python-pypubsub: Alternative to the deprecated wx.lib.pubsub API')
-makedepends=('mesa' 'glu' 'webkit2gtk' 'python-requests' 'python-setuptools' 'sip' 'doxygen' 'waf' 'python-attrdict')
+makedepends=('mesa' 'glu' 'webkit2gtk' 'python-requests' 'python-setuptools' 'python-attrdict')
checkdepends=('xorg-server-xvfb' 'python-pytest-forked' 'python-numpy')
provides=('python-wxpython')
conflicts=('python-wxpython')
-source=("https://wxpython.org/Phoenix/snapshot-builds/wxPython-$pkgver.tar.gz"
- "https://github.com/wxWidgets/wxWidgets/releases/download/v$_wxver/wxWidgets-$_wxver.tar.bz2")
-sha512sums=('f7fe342c70fd8fa66de67e1aeeb00290dbe2f995a4917a7bb7000d025cf5a084199bb1db6f23bc7b743448aa185f725af57aa9ed2b2ae8eead08ca69bb8e4137'
- 'e55e7c5ac7abcacf2ecff7c22e367db17ff5a077d3d5d2aa7589e8ba7cc6695cfa48c0f00bcfdffeda8dc4f974f97a857fb61b4b300a724f7687d710fbb23967')
-
-prepare() {
- cd "$_pkgname-$pkgver"
- rm -r ext/wxWidgets
- mv "$srcdir"/wxWidgets-$_wxver ext/wxWidgets
-}
+source=("https://wxpython.org/Phoenix/snapshot-builds/wxPython-$pkgver.tar.gz")
+sha512sums=('f7fe342c70fd8fa66de67e1aeeb00290dbe2f995a4917a7bb7000d025cf5a084199bb1db6f23bc7b743448aa185f725af57aa9ed2b2ae8eead08ca69bb8e4137')
build() {
cd "$_pkgname-$pkgver"
-
- # Recreate sip files with current wxWidgets
- rm -r sip/{cpp,gen}/*
- SIP=/usr/bin/sip DOXYGEN=/usr/bin/doxygen WAF=/usr/bin/waf \
- python build.py dox etg --nodoc sip build --use_syswx --release
+ python build.py build --release
}
check() {