summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordobedobedo2022-04-05 17:07:32 +0300
committerdobedobedo2022-04-05 17:07:32 +0300
commitf1c7a350650b0249b45ba4284bc7122c90e38467 (patch)
treeee72e0fe910fc753aa83eaa2c71eb9ddb3cffbe3
parentf5158fc7af6d6a85b73fbd555a3ab7b3020352b1 (diff)
downloadaur-f1c7a350650b0249b45ba4284bc7122c90e38467.tar.gz
Update for new wxgtk-dev
-rw-r--r--.SRCINFO4
-rw-r--r--Fix-wxGridEvent-GetRow-GetCol.patch117
-rw-r--r--PKGBUILD14
3 files changed, 6 insertions, 129 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 53287c5155e1..1af54dbb883c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-wxpython-dev
pkgdesc = Cross-platform GUI toolkit. Developer version
pkgver = 4.1.1
- pkgrel = 1
+ pkgrel = 2
url = https://www.wxpython.org
arch = x86_64
license = custom:wxWindows
@@ -19,8 +19,6 @@ pkgbase = python-wxpython-dev
provides = python-wxpython
conflicts = python-wxpython
source = https://files.pythonhosted.org/packages/source/w/wxPython/wxPython-4.1.1.tar.gz
- source = Fix-wxGridEvent-GetRow-GetCol.patch
sha512sums = 00924008b97bbecb824c3fffd46fc76a5a3115d9346eb95baccc6cca99c080aa80b586af42fece8a3b4d234f2d07ffa8b66b50a164c41cbd95abc9b139c32809
- sha512sums = 42523eeb28773538b07fe56346397ac7e26af554bd493bbffcde61b4a5557655b0f930447d3927c324ef674c7c1f0ae5b8b040d2324352388ed6ffc844d221e3
pkgname = python-wxpython-dev
diff --git a/Fix-wxGridEvent-GetRow-GetCol.patch b/Fix-wxGridEvent-GetRow-GetCol.patch
deleted file mode 100644
index 279e0732efea..000000000000
--- a/Fix-wxGridEvent-GetRow-GetCol.patch
+++ /dev/null
@@ -1,117 +0,0 @@
-diff --git a/sip/cpp/sip_gridwxGridEvent.cpp b/sip/cpp/sip_gridwxGridEvent.cpp
-index 0830b67..9aca2c4 100644
---- a/sip/cpp/sip_gridwxGridEvent.cpp
-+++ b/sip/cpp/sip_gridwxGridEvent.cpp
-@@ -32,8 +32,6 @@ public:
- * this class.
- */
- protected:
-- int GetRow() SIP_OVERRIDE;
-- int GetCol() SIP_OVERRIDE;
- ::wxEvent* Clone() const SIP_OVERRIDE;
- ::wxEventCategory GetEventCategory() const SIP_OVERRIDE;
-
-@@ -44,7 +42,7 @@ private:
- sipwxGridEvent(const sipwxGridEvent &);
- sipwxGridEvent &operator = (const sipwxGridEvent &);
-
-- char sipPyMethods[4];
-+ char sipPyMethods[2];
- };
-
- sipwxGridEvent::sipwxGridEvent(): ::wxGridEvent(), sipPySelf(SIP_NULLPTR)
-@@ -67,42 +65,12 @@ sipwxGridEvent::~sipwxGridEvent()
- sipInstanceDestroyedEx(&sipPySelf);
- }
-
--int sipwxGridEvent::GetRow()
--{
-- sip_gilstate_t sipGILState;
-- PyObject *sipMeth;
--
-- sipMeth = sipIsPyMethod(&sipGILState,&sipPyMethods[0],sipPySelf,SIP_NULLPTR,sipName_GetRow);
--
-- if (!sipMeth)
-- return ::wxGridEvent::GetRow();
--
-- extern int sipVH__grid_41(sip_gilstate_t, sipVirtErrorHandlerFunc, sipSimpleWrapper *, PyObject *);
--
-- return sipVH__grid_41(sipGILState, 0, sipPySelf, sipMeth);
--}
--
--int sipwxGridEvent::GetCol()
--{
-- sip_gilstate_t sipGILState;
-- PyObject *sipMeth;
--
-- sipMeth = sipIsPyMethod(&sipGILState,&sipPyMethods[1],sipPySelf,SIP_NULLPTR,sipName_GetCol);
--
-- if (!sipMeth)
-- return ::wxGridEvent::GetCol();
--
-- extern int sipVH__grid_41(sip_gilstate_t, sipVirtErrorHandlerFunc, sipSimpleWrapper *, PyObject *);
--
-- return sipVH__grid_41(sipGILState, 0, sipPySelf, sipMeth);
--}
--
- ::wxEvent* sipwxGridEvent::Clone() const
- {
- sip_gilstate_t sipGILState;
- PyObject *sipMeth;
-
-- sipMeth = sipIsPyMethod(&sipGILState,const_cast<char *>(&sipPyMethods[2]),sipPySelf,SIP_NULLPTR,sipName_Clone);
-+ sipMeth = sipIsPyMethod(&sipGILState,const_cast<char *>(&sipPyMethods[0]),sipPySelf,SIP_NULLPTR,sipName_Clone);
-
- if (!sipMeth)
- return ::wxGridEvent::Clone();
-@@ -117,7 +85,7 @@ int sipwxGridEvent::GetCol()
- sip_gilstate_t sipGILState;
- PyObject *sipMeth;
-
-- sipMeth = sipIsPyMethod(&sipGILState,const_cast<char *>(&sipPyMethods[3]),sipPySelf,SIP_NULLPTR,sipName_GetEventCategory);
-+ sipMeth = sipIsPyMethod(&sipGILState,const_cast<char *>(&sipPyMethods[1]),sipPySelf,SIP_NULLPTR,sipName_GetEventCategory);
-
- if (!sipMeth)
- return ::wxGridEvent::GetEventCategory();
-@@ -206,10 +174,9 @@ extern "C" {static PyObject *meth_wxGridEvent_GetCol(PyObject *, PyObject *);}
- static PyObject *meth_wxGridEvent_GetCol(PyObject *sipSelf, PyObject *sipArgs)
- {
- PyObject *sipParseErr = SIP_NULLPTR;
-- bool sipSelfWasArg = (!sipSelf || sipIsDerivedClass((sipSimpleWrapper *)sipSelf));
-
- {
-- ::wxGridEvent *sipCpp;
-+ const ::wxGridEvent *sipCpp;
-
- if (sipParseArgs(&sipParseErr, sipArgs, "B", &sipSelf, sipType_wxGridEvent, &sipCpp))
- {
-@@ -218,7 +185,7 @@ static PyObject *meth_wxGridEvent_GetCol(PyObject *sipSelf, PyObject *sipArgs)
- PyErr_Clear();
-
- Py_BEGIN_ALLOW_THREADS
-- sipRes = (sipSelfWasArg ? sipCpp-> ::wxGridEvent::GetCol() : sipCpp->GetCol());
-+ sipRes = sipCpp->GetCol();
- Py_END_ALLOW_THREADS
-
- if (PyErr_Occurred())
-@@ -277,10 +244,9 @@ extern "C" {static PyObject *meth_wxGridEvent_GetRow(PyObject *, PyObject *);}
- static PyObject *meth_wxGridEvent_GetRow(PyObject *sipSelf, PyObject *sipArgs)
- {
- PyObject *sipParseErr = SIP_NULLPTR;
-- bool sipSelfWasArg = (!sipSelf || sipIsDerivedClass((sipSimpleWrapper *)sipSelf));
-
- {
-- ::wxGridEvent *sipCpp;
-+ const ::wxGridEvent *sipCpp;
-
- if (sipParseArgs(&sipParseErr, sipArgs, "B", &sipSelf, sipType_wxGridEvent, &sipCpp))
- {
-@@ -289,7 +255,7 @@ static PyObject *meth_wxGridEvent_GetRow(PyObject *sipSelf, PyObject *sipArgs)
- PyErr_Clear();
-
- Py_BEGIN_ALLOW_THREADS
-- sipRes = (sipSelfWasArg ? sipCpp-> ::wxGridEvent::GetRow() : sipCpp->GetRow());
-+ sipRes = sipCpp->GetRow();
- Py_END_ALLOW_THREADS
-
- if (PyErr_Occurred())
diff --git a/PKGBUILD b/PKGBUILD
index 14f913b77fa8..120fc3095ee7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=python-wxpython-dev
_pkgname=wxPython
pkgver=4.1.1
-pkgrel=1
+pkgrel=2
pkgdesc='Cross-platform GUI toolkit. Developer version'
arch=('x86_64')
license=('custom:wxWindows')
@@ -18,22 +18,18 @@ makedepends=('mesa' 'glu' 'webkit2gtk' 'python-requests' 'python-setuptools')
checkdepends=('xorg-server-xvfb' 'python-pytest-forked' 'python-numpy')
provides=('python-wxpython')
conflicts=('python-wxpython')
-source=("https://files.pythonhosted.org/packages/source/w/wxPython/wxPython-$pkgver.tar.gz"
- 'Fix-wxGridEvent-GetRow-GetCol.patch')
-sha512sums=('00924008b97bbecb824c3fffd46fc76a5a3115d9346eb95baccc6cca99c080aa80b586af42fece8a3b4d234f2d07ffa8b66b50a164c41cbd95abc9b139c32809'
- '42523eeb28773538b07fe56346397ac7e26af554bd493bbffcde61b4a5557655b0f930447d3927c324ef674c7c1f0ae5b8b040d2324352388ed6ffc844d221e3')
+source=("https://files.pythonhosted.org/packages/source/w/wxPython/wxPython-$pkgver.tar.gz")
+sha512sums=('00924008b97bbecb824c3fffd46fc76a5a3115d9346eb95baccc6cca99c080aa80b586af42fece8a3b4d234f2d07ffa8b66b50a164c41cbd95abc9b139c32809')
prepare() {
cd "$_pkgname-$pkgver"
-
- # Fix https://github.com/wxWidgets/Phoenix/issues/1909
- patch -p1 -i ../Fix-wxGridEvent-GetRow-GetCol.patch
+ sed -i "s|WX_CONFIG = 'wx-config'|WX_CONFIG = 'wx-config-gtk3'|" build.py
}
build() {
cd "$_pkgname-$pkgver"
- python build.py build --use_syswx --release
+ python build.py build --release
}
check() {