summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTobias Bachmann2018-01-24 14:19:51 +0100
committerTobias Bachmann2018-01-24 14:19:51 +0100
commitcd0f02102464bea885778f28f0ea2e2793417f39 (patch)
tree95494eb6d3253c80a8f05afe91d7b17d6029fb47
downloadaur-cd0f02102464bea885778f28f0ea2e2793417f39.tar.gz
This is now a split package and provides both Python 3 and Python 2 versions of wxPython Phoenix
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD43
2 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2635dae149b5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = python-wxpython-phoenix
+ pkgdesc = wxPython 4.x. This is a split package providing both Python 2 and Python 3 versions of wxPython 4.x (aka wxPython Phoenix)
+ pkgver = 4.0.0b2
+ pkgrel = 1
+ url = https://github.com/wxWidgets/Phoenix
+ arch = any
+ license = custom:wxWindows
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
+ makedepends = mesa
+ makedepends = glu
+ makedepends = git
+ makedepends = libpng
+ makedepends = libjpeg-turbo
+ makedepends = libtiff
+ makedepends = sdl
+ makedepends = gst-plugins-base
+ makedepends = libnotify
+ makedepends = freeglut
+ makedepends = gtk3
+ makedepends = webkit2gtk
+ depends = python
+ provides = wxpython-phoenix
+ conflicts = wxpython-phoenix-bin
+ conflicts = wxpython-phoenix-git
+ options = !emptydirs
+ source = https://files.pythonhosted.org/packages/source/w/wxPython/wxPython-4.0.0b2.tar.gz
+ sha256sums = 1d34c3e2ff475ca6d2a11e8addd0333e4f616cc74f6bfcda5c6e96f51478666d
+
+pkgname = python-wxpython-phoenix
+
+pkgname = python2-wxpython-phoenix
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fb1d153bc774
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Tobias Bachmann <tobachmann@gmx.de>
+pkgbase=('python-wxpython-phoenix')
+pkgname=('python-wxpython-phoenix' 'python2-wxpython-phoenix')
+pkgver=4.0.0b2
+pkgrel=1
+pkgdesc="wxPython 4.x. This is a split package providing both Python 2 and Python 3 versions of wxPython 4.x (aka wxPython Phoenix)"
+_name=wxPython
+arch=('any')
+url="https://github.com/wxWidgets/Phoenix"
+license=('custom:wxWindows')
+groups=()
+depends=('python')
+makedepends=('python-setuptools' 'python2-setuptools' 'mesa' 'glu' 'git' 'libpng' 'libjpeg-turbo' 'libtiff' 'sdl' 'gst-plugins-base' 'libnotify' 'freeglut' 'gtk3' 'webkit2gtk')
+provides=('wxpython-phoenix')
+conflicts=('wxpython-phoenix-bin' 'wxpython-phoenix-git')
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha256sums=('1d34c3e2ff475ca6d2a11e8addd0333e4f616cc74f6bfcda5c6e96f51478666d')
+
+package_python-wxpython-phoenix() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ # We have to rename the files in /usr/bin to avoid conflicts with python2 wxPython
+ # I've used the naming convention established in wxpython-phoenix-git
+ cd "$pkgdir/usr/bin"
+ for file in *; do mv ${file} ${file}-phoenix; done
+ chmod 644 "$pkgdir"/usr/lib/python3.6/site-packages/wxPython-4.0.0b2-py3.6.egg-info/*
+}
+
+package_python2-wxpython-phoenix() {
+ cd "$srcdir/$_name-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+ # We have to rename the files in /usr/bin to avoid conflicts with python2 wxPython
+ # I've used the naming convention established in wxpython-phoenix-git
+ cd "$pkgdir/usr/bin"
+ for file in *; do mv ${file} ${file}-phoenix2; done
+ chmod 644 "$pkgdir"/usr/lib/python2.7/site-packages/wxPython-4.0.0b2-py2.7.egg-info/*
+}
+
+# vim:set ts=2 sw=2 et: