summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPieter Goetschalckx2018-07-05 15:58:07 +0200
committerPieter Goetschalckx2018-07-05 15:58:07 +0200
commit387365fab8aaf3b9fa2df13f4a0f3bee27a9ba67 (patch)
treeaaf126d791927f7648565d0a4611e7012c96e309
downloadaur-387365fab8aaf3b9fa2df13f4a0f3bee27a9ba67.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..63ea45bb56a5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-x256
+ pkgdesc = Find the nearest xterm 256 color index for an RGB
+ pkgver = r20.d4bc9f7
+ pkgrel = 1
+ url = https://github.com/magarcia/python-x256
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python
+ source = git+https://github.com/magarcia/python-x256
+ sha256sums = SKIP
+
+pkgname = python-x256
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ecb3513b0d1b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Pieter Goetschalckx <3.14.e.ter <at> gmail <dot> com>
+
+pkgname=python-x256
+pkgver=r20.d4bc9f7
+pkgrel=1
+pkgdesc="Find the nearest xterm 256 color index for an RGB"
+arch=('any')
+url="https://github.com/magarcia/python-x256"
+license=('MIT')
+depends=('python')
+makedepends=('git' 'python-setuptools')
+source=("git+https://github.com/magarcia/$pkgname")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$pkgname"
+ python setup.py build
+}
+
+package() {
+ cd "$pkgname"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}