summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRich Li2016-01-21 21:29:12 -0800
committerRich Li2016-01-21 21:29:12 -0800
commit7df3165e65165d8ed8d65860251c0e25e5b89d7a (patch)
tree306e3e5dac11d09b83af63f176c545aa9825f858
parent5b882a063e83372e5639935218d53fd0ba79fff7 (diff)
downloadaur-7df3165e65165d8ed8d65860251c0e25e5b89d7a.tar.gz
Update to version 0.7.0, rename to python-xarray
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD22
2 files changed, 21 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 54c6e9df2a8f..1f8d3084af21 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,10 @@
-pkgbase = python-xray
+# Generated by mksrcinfo v8
+# Fri Jan 22 05:28:53 UTC 2016
+pkgbase = python-xarray
pkgdesc = N-D labeled arrays and datasets in Python
- pkgver = 0.6.1
+ pkgver = 0.7.0
pkgrel = 1
- url = https://pypi.python.org/pypi/xray
+ url = https://pypi.python.org/pypi/xarray
arch = any
license = Apache
checkdepends = python-nose
@@ -14,10 +16,10 @@ pkgbase = python-xray
optdepends = python-scipy: OPeNDAP support
optdepends = python-matplotlib: Plotting support
optdepends = python-dask: Enable out-of-core parallel computation
- source = https://github.com/xray/xray/archive/v0.6.1.tar.gz
- md5sums = 201ef4249182771a4013e256d330bf96
- sha1sums = a4ac7c719a76bfa47ab5dec2d63af4468461754b
- sha256sums = 758baad3c29a9e7f505e55314f3a05ba9cce55c2759433dabd81a58c9436abce
+ source = https://github.com/xarray/xarray/archive/v0.7.0.tar.gz
+ md5sums = 895faa8bc439a0bdf3e41e5a74c137b2
+ sha1sums = 4dc3bb7f39d99c5fda7065d136438634bc00cfb3
+ sha256sums = 18a6ffb10283007fb240456196c144950691d54f5953ba3d7fb5eb4d0c133cfa
-pkgname = python-xray
+pkgname = python-xarray
diff --git a/PKGBUILD b/PKGBUILD
index 4e88d3267632..10857f2d5490 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Rich Li <rich@dranek.com>
-pkgname='python-xray'
-pkgver=0.6.1
+pkgname='python-xarray'
+pkgver=0.7.0
pkgrel=1
pkgdesc="N-D labeled arrays and datasets in Python"
-url="https://pypi.python.org/pypi/xray"
+url="https://pypi.python.org/pypi/xarray"
arch=('any')
license=('Apache')
makedepends=('python-setuptools')
@@ -14,25 +14,25 @@ optdepends=('python-netcdf4: NetCDF4 support'
'python-matplotlib: Plotting support'
'python-dask: Enable out-of-core parallel computation')
checkdepends=('python-nose')
-#source=(https://pypi.python.org/packages/source/x/xray/xray-"$pkgver".tar.gz)
+#source=(https://pypi.python.org/packages/source/x/xarray/xarray-"$pkgver".tar.gz)
# I'm using the Github source instead of the PyPI source since the Github source includes the data files used for testing
-source=(https://github.com/xray/xray/archive/v"$pkgver".tar.gz)
-md5sums=('201ef4249182771a4013e256d330bf96')
-sha1sums=('a4ac7c719a76bfa47ab5dec2d63af4468461754b')
-sha256sums=('758baad3c29a9e7f505e55314f3a05ba9cce55c2759433dabd81a58c9436abce')
+source=(https://github.com/xarray/xarray/archive/v"$pkgver".tar.gz)
+md5sums=('895faa8bc439a0bdf3e41e5a74c137b2')
+sha1sums=('4dc3bb7f39d99c5fda7065d136438634bc00cfb3')
+sha256sums=('18a6ffb10283007fb240456196c144950691d54f5953ba3d7fb5eb4d0c133cfa')
build() {
- cd "$srcdir/xray-$pkgver"
+ cd "$srcdir/xarray-$pkgver"
python setup.py build
}
check() {
- cd "$srcdir/xray-$pkgver"
+ cd "$srcdir/xarray-$pkgver"
nosetests
}
package() {
- cd "$srcdir/xray-$pkgver"
+ cd "$srcdir/xarray-$pkgver"
python setup.py install --prefix=/usr --root="$pkgdir/" --optimize=1
}