summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRich Li2017-11-20 13:49:40 -0800
committerRich Li2017-11-20 13:49:40 -0800
commit8183c4e0a4a79dd921fd3986d9dc1b72aff58ed1 (patch)
treedf927e8a0156bbf90b12517329d9ad0489932a3f
parenta35ee7cab59c55b7f08bc8138ad9f2cdb5955712 (diff)
downloadaur-8183c4e0a4a79dd921fd3986d9dc1b72aff58ed1.tar.gz
Update to version 0.10.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0aaccadab953..dadd7d3e6fde 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-xarray
pkgdesc = N-D labeled arrays and datasets in Python
- pkgver = 0.9.6
+ pkgver = 0.10.0
pkgrel = 1
url = http://xarray.pydata.org
arch = any
@@ -15,10 +15,10 @@ pkgbase = python-xarray
optdepends = python-matplotlib: Plotting support
optdepends = python-dask: Enable out-of-core parallel computation
replaces = python-xray
- source = python-xarray-0.9.6.tar.gz::https://github.com/pydata/xarray/archive/v0.9.6.tar.gz
- md5sums = 980aa689524338de077d8f889e901327
- sha1sums = f49c7e9f5c2cf42a3c3427815c0bd08dcaefa135
- sha256sums = 4b68f2fa5158123f87b158015374e035471dbe00d10e445cb43a5e4ab11045e1
+ source = python-xarray-0.10.0.tar.gz::https://github.com/pydata/xarray/archive/v0.10.0.tar.gz
+ md5sums = 978823622e0acbd2fcc7ffd01857685a
+ sha1sums = 591f1b0bb82716de7a9325078d0a461178006357
+ sha256sums = 9191838f82467b3e2cc11670f6573202548ac9562d6d3abba6bcba34fc1b66f0
pkgname = python-xarray
diff --git a/PKGBUILD b/PKGBUILD
index a996411300cf..75437ce7e413 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Rich Li <rich@dranek.com>
pkgname='python-xarray'
-pkgver=0.9.6
+pkgver=0.10.0
pkgrel=1
pkgdesc="N-D labeled arrays and datasets in Python"
url="http://xarray.pydata.org"
@@ -19,19 +19,16 @@ replaces=('python-xray')
#source=(https://pypi.python.org/packages/source/x/xarray/xarray-"$pkgver".tar.gz)
# I'm using the Github source instead of the PyPI source since the Github source includes the data files used for testing
source=("$pkgname-$pkgver.tar.gz::https://github.com/pydata/xarray/archive/v$pkgver.tar.gz")
-md5sums=('980aa689524338de077d8f889e901327')
-sha1sums=('f49c7e9f5c2cf42a3c3427815c0bd08dcaefa135')
-sha256sums=('4b68f2fa5158123f87b158015374e035471dbe00d10e445cb43a5e4ab11045e1')
+md5sums=('978823622e0acbd2fcc7ffd01857685a')
+sha1sums=('591f1b0bb82716de7a9325078d0a461178006357')
+sha256sums=('9191838f82467b3e2cc11670f6573202548ac9562d6d3abba6bcba34fc1b66f0')
build() {
cd "$srcdir/xarray-$pkgver"
python setup.py build
}
-# NB: the test suite currently fails due to a recent change in Numpy (from 1.11
-# to 1.12), which in turn affected bottleneck. Once bottleneck releases the
-# next version (current is 1.2.0), then it should be fixed. See
-# https://github.com/pydata/xarray/issues/1208.
+# NB: the default test suite seems to require dask being installed
# check() {
# cd "$srcdir/xarray-$pkgver"
# pytest xarray