summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRich Li2015-11-07 10:24:06 -0700
committerRich Li2015-11-07 10:24:06 -0700
commit88c0ac534eaada0b1c58b298bb0f812e1769b1b9 (patch)
tree5d2e0e52f1033159bc16696538dc0654735ef76b
parent7a714bc471ada096ecb1a59e116256a751f643ca (diff)
downloadaur-88c0ac534eaada0b1c58b298bb0f812e1769b1b9.tar.gz
Update to version 0.6.1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD12
2 files changed, 14 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aefa0b1bc226..8e001c8b0ceb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-xray
pkgdesc = N-D labeled arrays and datasets in Python
- pkgver = 0.6.0
+ pkgver = 0.6.1
pkgrel = 1
url = https://pypi.python.org/pypi/xray
arch = any
@@ -13,10 +13,12 @@ pkgbase = python-xray
optdepends = python-bottleneck: Faster NaN operations
optdepends = python-cyordereddict: Speed up most internal operations
optdepends = python-scipy: OPeNDAP support
- source = https://github.com/xray/xray/archive/v0.6.0.tar.gz
- md5sums = b9baf91aa9f6f062eb22bc99b4fe2745
- sha1sums = 3241c32884f4ca78244c1071ab0035e63e8bb557
- sha256sums = 556e3245ff598e2ec789c8212c622060db54f6ebfe1346dbb5439bf704ae5742
+ optdepends = python-matplotlib: Plotting support
+ optdepends = python-dask: Enable out-of-core parallel computation
+ source = https://github.com/xray/xray/archive/v0.6.1.tar.gz
+ md5sums = 201ef4249182771a4013e256d330bf96
+ sha1sums = a4ac7c719a76bfa47ab5dec2d63af4468461754b
+ sha256sums = 758baad3c29a9e7f505e55314f3a05ba9cce55c2759433dabd81a58c9436abce
pkgname = python-xray
diff --git a/PKGBUILD b/PKGBUILD
index cd38b13a40b8..0cdd423bca50 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Rich Li <rich@dranek.com>
pkgname='python-xray'
-pkgver=0.6.0
+pkgver=0.6.1
pkgrel=1
pkgdesc="N-D labeled arrays and datasets in Python"
url="https://pypi.python.org/pypi/xray"
@@ -11,14 +11,16 @@ depends=('python-numpy' 'python-pandas')
optdepends=('python-netcdf4: NetCDF4 support'
'python-bottleneck: Faster NaN operations'
'python-cyordereddict: Speed up most internal operations'
- 'python-scipy: OPeNDAP support')
+ 'python-scipy: OPeNDAP support'
+ 'python-matplotlib: Plotting support'
+ 'python-dask: Enable out-of-core parallel computation')
checkdepends=('python-nose')
#source=(https://pypi.python.org/packages/source/x/xray/xray-"$pkgver".tar.gz)
# I'm using the Github source instead of the PyPI source since the Github source includes the data files used for testing
source=(https://github.com/xray/xray/archive/v"$pkgver".tar.gz)
-md5sums=('b9baf91aa9f6f062eb22bc99b4fe2745')
-sha1sums=('3241c32884f4ca78244c1071ab0035e63e8bb557')
-sha256sums=('556e3245ff598e2ec789c8212c622060db54f6ebfe1346dbb5439bf704ae5742')
+md5sums=('201ef4249182771a4013e256d330bf96')
+sha1sums=('a4ac7c719a76bfa47ab5dec2d63af4468461754b')
+sha256sums=('758baad3c29a9e7f505e55314f3a05ba9cce55c2759433dabd81a58c9436abce')
build() {
cd "$srcdir/xray-$pkgver"