summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRich Li2016-08-08 12:37:46 -0700
committerRich Li2016-08-08 12:37:46 -0700
commitf0f49291f2a44825b2337f4ec3f9629462e05257 (patch)
tree740b22471b4e007358c751136b3eaef9c8570a44
parentf5fa02bd38d4d06c29b4d22456daa3f3085de951 (diff)
downloadaur-f0f49291f2a44825b2337f4ec3f9629462e05257.tar.gz
Switch from nose to pytest
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0dd7d470fffb..e22a32fe14e2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,7 +5,7 @@ pkgbase = python-xarray
url = http://xarray.pydata.org
arch = any
license = Apache
- checkdepends = python-nose
+ checkdepends = python-pytest
makedepends = python-setuptools
depends = python-numpy
depends = python-pandas
diff --git a/PKGBUILD b/PKGBUILD
index 3f11da6872d8..5293969f7697 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@ optdepends=('python-netcdf4: NetCDF4 support'
'python-scipy: OPeNDAP support'
'python-matplotlib: Plotting support'
'python-dask: Enable out-of-core parallel computation')
-checkdepends=('python-nose')
+checkdepends=('python-pytest')
replaces=('python-xray')
#source=(https://pypi.python.org/packages/source/x/xarray/xarray-"$pkgver".tar.gz)
# I'm using the Github source instead of the PyPI source since the Github source includes the data files used for testing
@@ -29,7 +29,7 @@ build() {
check() {
cd "$srcdir/xarray-$pkgver"
- nosetests
+ py.test xarray
}
package() {