summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Mailänder2022-12-22 10:54:19 +0100
committerMatthias Mailänder2022-12-22 10:54:19 +0100
commit431da9ec0521f18a90da88ea92bf645e731a3ff4 (patch)
treeafe2889eeaabc6227aa3b28082ff29643b0ee8ab
downloadaur-431da9ec0521f18a90da88ea92bf645e731a3ff4.tar.gz
Initial packaging.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6e0fe1d6ea82
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-xdgenvpy
+ pkgdesc = Another XDG Base Directory Specification utility.
+ pkgver = 2.3.5
+ pkgrel = 1
+ url = https://gitlab.com/deliberist/xdgenvpy
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ makedepends = python-wheel
+ makedepends = python-pip
+ source = https://files.pythonhosted.org/packages/source/x/xdgenvpy/xdgenvpy-2.3.5.tar.gz
+ sha256sums = 31e6c2ba68061000d09f74444db0520da90d2fb694a3b2c23551b06ac8d9642f
+
+pkgname = python-xdgenvpy
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9bf4ca7160a5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Matthias Mailänder <matthias@mailaender.name>
+
+pkgname=python-xdgenvpy
+_name=${pkgname//python-}
+pkgver=2.3.5
+pkgrel=1
+pkgdesc="Another XDG Base Directory Specification utility."
+arch=('any')
+url="https://gitlab.com/deliberist/xdgenvpy"
+license=('MIT')
+makedepends=('python-setuptools' 'python-wheel' 'python-pip')
+source=("https://files.pythonhosted.org/packages/source/${_name:0:1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha256sums=('31e6c2ba68061000d09f74444db0520da90d2fb694a3b2c23551b06ac8d9642f')
+
+build() {
+ cd $_name-$pkgver
+ pip3 freeze > requirements.txt
+ pip3 freeze > requirements-test.txt
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd $_name-$pkgver
+ python -m installer --destdir="$pkgdir" dist/*.whl
+
+ install -Dm644 LICENSE.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE.md"
+}