summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime “pep” Buquet2018-05-11 17:20:35 +0200
committerMaxime “pep” Buquet2018-05-11 17:20:35 +0200
commite45d04eb81999db89e2e879adf44faac44bfa2ec (patch)
treeabae9deab528bfdecf74f5f9ea1985fa489cbf91
downloadaur-e45d04eb81999db89e2e879adf44faac44bfa2ec.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD38
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4507acbffb1f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-xeddsa-git
+ pkgdesc = A python implementation of the XEdDSA signature scheme
+ pkgver = r17.8334136
+ pkgrel = 1
+ url = https://github.com/Syndace/python-xeddsa
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ makedepends = libsodium
+ depends = python-pynacl
+ provides = python-xeddsa
+ conflicts = python-xeddsa
+ source = python-xeddsa::git+https://github.com/Syndace/python-xeddsa.git
+ sha256sums = SKIP
+
+pkgname = python-xeddsa-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cc5ae05ad3dd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Maxime "pep" Buquet <archlinux@bouah.net>
+
+_pkgname=python-xeddsa
+pkgname=${_pkgname}-git
+pkgver=r17.8334136
+pkgrel=1
+pkgdesc="A python implementation of the XEdDSA signature scheme"
+url='https://github.com/Syndace/python-xeddsa'
+license=('MIT')
+arch=('any')
+depends=('python-pynacl')
+makedepends=('python-setuptools' 'libsodium')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("${_pkgname}::git+https://github.com/Syndace/python-xeddsa.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${_pkgname}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "${_pkgname}/ref10"
+ sed -i -e 's,usr/local/include,usr/include,' Makefile
+}
+
+build() {
+ cd "${_pkgname}/ref10"
+ make
+}
+
+package() {
+ cd ${_pkgname}
+
+ python3 setup.py install --root="${pkgdir}" --optimize=1
+ install -Dm 644 ref10/bin/libref10.so "${pkgdir}/usr/lib"
+}