summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Kudelin2023-07-07 14:11:25 +0300
committerAnton Kudelin2023-07-07 14:11:25 +0300
commitfedf81742cb46729a49aad3dd3fac5ca2a9a1358 (patch)
tree389e7f0ea09e61f406d68d4ac2e4bbed98b69c02
parent7d5c24f63476985b5064066397aebcf9641f0c4b (diff)
downloadaur-fedf81742cb46729a49aad3dd3fac5ca2a9a1358.tar.gz
building via wheel
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD18
2 files changed, 17 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6abe638bd20d..630daab0d1a8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,16 @@
pkgbase = python-xgboost
pkgdesc = Gradient Boosting Library for Python
pkgver = 1.7.6
- pkgrel = 1
+ pkgrel = 2
url = https://xgboost.ai
arch = x86_64
arch = aarch64
license = Apache
- makedepends = cmake
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
+ makedepends = python-wheel
+ makedepends = cmake
depends = python-scikit-learn
depends = python-pandas
depends = python-matplotlib
diff --git a/PKGBUILD b/PKGBUILD
index 3b5d21d7f87f..048d8d88c19b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,15 @@ _pyname=xgboost
pkgname=python-$_pyname
pkgver=1.7.6
_dmlc_ver=0.5
-pkgrel=1
+pkgrel=2
pkgdesc="Gradient Boosting Library for Python"
arch=(x86_64 aarch64)
url="https://xgboost.ai"
license=(Apache)
depends=(python-scikit-learn python-pandas python-matplotlib python-pyarrow
openmpi)
-makedepends=(cmake python-setuptools)
+makedepends=(python-build python-installer python-setuptools python-wheel
+ cmake)
optdepends=('apache-spark: Distributed XGBoost with PySpark' 'python-pytest')
provides=(python-$_pyname)
conflicts=(python-$_pyname-git)
@@ -44,12 +45,17 @@ build() {
-DProtobuf_PROTOC_EXECUTABLE=/usr/bin/protoc \
-DRABIT_BUILD_MPI=ON
cmake --build build
+
+ cd $_pyname-$pkgver/python-package
+ python -m build \
+ --wheel \
+ --no-isolation \
+ --skip-dependency-check
}
package() {
cd "$srcdir/$_pyname-$pkgver/python-package"
- python setup.py install \
- --prefix=/usr \
- --root="$pkgdir" \
- --optimize=2
+ python -m installer dist/*.whl \
+ --destdir="$pkgdir" \
+ --compile-bytecode=2
}