summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichał Wojdyła2022-03-27 12:20:04 +0200
committerMichał Wojdyła2022-03-27 12:20:04 +0200
commitb932668744022fa11eb128ab2efbad115b755174 (patch)
tree9371682ada9acdf96c4612f7e32a36452967ef45
parent3e352cc497ec7625b463d91ff5f7a6d47b9548de (diff)
downloadaur-b932668744022fa11eb128ab2efbad115b755174.tar.gz
update to 0.2.6, disable pdf docs
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD18
2 files changed, 14 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 724aef0f6799..63993317d7eb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,19 @@
pkgbase = python-xhtml2pdf
pkgdesc = A library for converting HTML into PDFs using ReportLab
- pkgver = 0.2.5
- pkgrel = 2
+ pkgver = 0.2.6
+ pkgrel = 1
url = https://github.com/xhtml2pdf/xhtml2pdf
arch = any
license = Apache
makedepends = python-setuptools
makedepends = python-sphinx_rtd_theme
- makedepends = texlive-latexextra
makedepends = python-wheel
depends = python-arabic-reshaper
depends = python-bidi
depends = python-reportlab
- depends = python-pypdf2
+ depends = python-pypdf3
depends = python-html5lib
- source = https://github.com/xhtml2pdf/xhtml2pdf/archive/0.2.5.tar.gz
- sha256sums = 6cb3ff827861bc53e88a5ff99fe6b166dabe2861a7bc51f0817009436a7dd4b8
+ source = https://github.com/xhtml2pdf/xhtml2pdf/archive/v0.2.6.tar.gz
+ sha256sums = ce0e2b711f5200f46caf2a67008700fb1de0a761f2ae92d30b21e158de05912e
pkgname = python-xhtml2pdf
diff --git a/PKGBUILD b/PKGBUILD
index 32242b31166e..cb2e93f52902 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: Michał Wojdyła < micwoj9292 at gmail dot com >
pkgname=python-xhtml2pdf
_name=${pkgname#python-}
-pkgver=0.2.5
-pkgrel=2
+pkgver=0.2.6
+pkgrel=1
pkgdesc="A library for converting HTML into PDFs using ReportLab"
arch=(any)
url="https://github.com/xhtml2pdf/xhtml2pdf"
@@ -11,19 +11,19 @@ license=('Apache')
depends=(python-arabic-reshaper
python-bidi
python-reportlab
- python-pypdf2
+ python-pypdf3
python-html5lib)
makedepends=(python-setuptools
python-sphinx_rtd_theme
- texlive-latexextra
+# texlive-latexextra
python-wheel)
-source=("https://github.com/${_name}/${_name}/archive/${pkgver}.tar.gz" )
-sha256sums=('6cb3ff827861bc53e88a5ff99fe6b166dabe2861a7bc51f0817009436a7dd4b8')
+source=("https://github.com/${_name}/${_name}/archive/v${pkgver}.tar.gz" )
+sha256sums=('ce0e2b711f5200f46caf2a67008700fb1de0a761f2ae92d30b21e158de05912e')
build() {
cd ${_name}-${pkgver}
python setup.py build
- (cd doc && make html)
- (cd doc && make latexpdf)
+ (cd doc && make html)
+# (cd doc && make latexpdf)
}
check() {
@@ -36,5 +36,5 @@ package() {
python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
mkdir -p ${pkgdir}/usr/share/doc/${pkgname}
cp ${srcdir}/${_name}-${pkgver}/doc/build/html ${pkgdir}/usr/share/doc/${pkgname} -R
- cp ${srcdir}/${_name}-${pkgver}/doc/build/latex/${_name}.pdf ${pkgdir}/usr/share/doc/${_name}.pdf
+# cp ${srcdir}/${_name}-${pkgver}/doc/build/latex/${_name}.pdf ${pkgdir}/usr/share/doc/${_name}.pdf
}