summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxpt2021-11-04 02:03:36 -0300
committerxpt2021-11-04 02:03:36 -0300
commitd7e76d09a95d2773505591bd55b4a8d2b53cb44a (patch)
treeab33cac2c01268ed1aa8f586f10a2a1a13e58df1
downloadaur-d7e76d09a95d2773505591bd55b4a8d2b53cb44a.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..555b9b0d2a04
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-xlutils
+ pkgdesc = Utilities for working with Excel files that require both xlrd and xlwt
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = http://www.python-excel.org
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = python-xlrd
+ depends = python-xlwt
+ optdepends = python-errorhandler: needed for ErrorFilter support
+ source = https://files.pythonhosted.org/packages/93/fe/af6d73e4bc7b0ce359d34bebb2e8d4d129763acfecd66a3a7efc587e54c9/xlutils-2.0.0.tar.gz
+ md5sums = 7a6a339ddaacabce244341582ee61353
+
+pkgname = python-xlutils
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..168dcd10c55c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+#Automatically generated by pip2arch on 2021-11-04
+
+pkgname=python-xlutils
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="Utilities for working with Excel files that require both xlrd and xlwt"
+url="http://www.python-excel.org"
+depends=('python' 'python-xlrd' 'python-xlwt')
+makedepends=('python-setuptools')
+optdepends=('python-errorhandler: needed for ErrorFilter support')
+license=('MIT')
+arch=('any')
+source=('https://files.pythonhosted.org/packages/93/fe/af6d73e4bc7b0ce359d34bebb2e8d4d129763acfecd66a3a7efc587e54c9/xlutils-2.0.0.tar.gz')
+md5sums=('7a6a339ddaacabce244341582ee61353')
+
+build() {
+ cd $srcdir/xlutils-2.0.0
+ python setup.py build
+}
+
+package() {
+ cd $srcdir/xlutils-2.0.0
+ python setup.py install --root="$pkgdir" --optimize=1
+}