summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAutumn Boyhan2021-10-18 08:56:44 -0400
committerAutumn Boyhan2021-10-18 08:56:44 -0400
commit8a8b8975b54296b21a9d9627b5c726dfc4844f19 (patch)
tree9e3f84212336ee0b227706f37c14dd512229ad6b
downloadaur-8a8b8975b54296b21a9d9627b5c726dfc4844f19.tar.gz
Initial commit for v2021.10.11.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD23
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cd7f20af444f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-xsge
+ pkgdesc = xSGE is a collection of higher-level extensions for the SGE which enhance the core functionality in an implementation-independent way.
+ pkgver = 2021.10.11
+ pkgrel = 1
+ url = https://python-sge.github.io/
+ arch = x86_64
+ license = LGPL
+ makedepends = python-setuptools
+ depends = python
+ depends = python-pygame
+ depends = python-sge
+ provides = python-xsge
+ conflicts = python-xsge
+ source = https://github.com/python-sge/xsge/archive/refs/tags/v2021.10.11.tar.gz
+ md5sums = 3e0f3e7e57d3cdb6d868c0e72db1e02a
+
+pkgname = python-xsge
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..922bc56b143c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Autumn Boyhan <autumn@crisismodel.com>
+
+pkgname=python-xsge
+_pkgname=xsge
+pkgver=2021.10.11
+pkgrel=1
+pkgdesc="xSGE is a collection of higher-level extensions for the SGE which
+enhance the core functionality in an implementation-independent way."
+arch=('x86_64')
+url="https://python-sge.github.io/"
+license=('LGPL')
+depends=('python' 'python-pygame' 'python-sge')
+makedepends=('python-setuptools')
+provides=('python-xsge')
+conflicts=('python-xsge')
+_name=${pkgname#python-}
+source=("https://github.com/python-sge/xsge/archive/refs/tags/v${pkgver}.tar.gz")
+md5sums=('3e0f3e7e57d3cdb6d868c0e72db1e02a')
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}