summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Glamsch2018-11-30 20:08:22 +0100
committerThomas Glamsch2018-11-30 20:08:22 +0100
commit123c8f1fc88ce530286a50e9d111191d9dcd331e (patch)
treedde5249b51abae0a1f433af803c0cb66192c5b50
downloadaur-123c8f1fc88ce530286a50e9d111191d9dcd331e.tar.gz
Create an AUR package for xwiimote python bindings.
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD39
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..56688e97af26
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-xwiimote-git
+ pkgdesc = Open Source Nintendo Wii Remote Linux Device Driver (Python Bindings)
+ pkgver = 20131028
+ pkgrel = 1
+ url = http://dvdhrm.github.io/xwiimote
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = xwiimote
+ source = git://github.com/dvdhrm/xwiimote-bindings.git
+ md5sums = SKIP
+
+pkgname = python-xwiimote-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d681364c01c2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*.pkg.tar.xz
+xwiimote-bindings/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..19bd6b93a7c3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Thomas Glamsch <thomas (dot) glamsch (at) gmail (dot) com>
+
+pkgname=python-xwiimote-git
+_pkgname=xwiimote-bindings
+pkgver=20131028
+pkgrel=1
+pkgdesc="Open Source Nintendo Wii Remote Linux Device Driver (Python Bindings)"
+url="http://dvdhrm.github.io/xwiimote"
+license=('MIT')
+arch=('i686' 'x86_64')
+depends=('xwiimote')
+makedepends=('git')
+source=('git://github.com/dvdhrm/xwiimote-bindings.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git log -1 --format=%cd --date=%Y%m%d
+}
+
+prepare() {
+ cd "$srcdir/$_pkgname"
+ NOCONFIGURE=1 ./autogen.sh
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ make DESTDIR="$pkgdir" install
+ rm -rf "$pkgdir/usr/lib/perl5"
+ install -m644 -D LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: