summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMoetaYuko2022-11-27 18:58:57 +0800
committerMoetaYuko2022-11-27 18:58:57 +0800
commit1dbd80d8e10d022c3ff18969c5d8254f00e4fe17 (patch)
tree467fbc3c752f946a2cdadb07ed1813829b0b3797
parent30fe5e28104732d77afde6f84269dc28101e6692 (diff)
downloadaur-1dbd80d8e10d022c3ff18969c5d8254f00e4fe17.tar.gz
Bump
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD24
2 files changed, 18 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index acc7213284fa..31364530c213 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = python-yalafi
pkgdesc = Yet another LaTeX filter
- pkgver = 1.3.1
+ pkgver = 1.4.0
pkgrel = 1
- url = https://github.com/matze-dd/YaLafi
+ url = https://github.com/torik42/YaLafi
arch = any
license = GPL3
- makedepends = python-setuptools
- depends = python3
+ makedepends = python-pyproject2setuppy
+ depends = python
depends = languagetool
- source = https://github.com/matze-dd/YaLafi/archive/1.3.1.zip
+ source = https://github.com/torik42/YaLafi/archive/1.4.0.zip
source = ltdirectory.patch
- sha256sums = 7e2985c11f6001d586e09a5cf2838479fe12600cfff315933941952110c67259
+ sha256sums = 0062175c40659eb16beff26cb934f073c87f6e6e5f56657b713eb401ec6973cc
sha256sums = ff59913ed6c4cc63dcf47f9604d5a096bd30e152f14e36ec53fa1e37793e5c10
pkgname = python-yalafi
diff --git a/PKGBUILD b/PKGBUILD
index f556e800df37..2d7dd0d42d1c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,33 @@
-# Maintainer: dianlujitao <dianlujitao at gmail dot com>
+# Maintainer: MoetaYuko <loli at yuko dot moe>
# Contributor: Joakim Repomaa <aur@j.repomaa.com>
pkgname=python-yalafi
-pkgver=1.3.1
+pkgver=1.4.0
pkgrel=1
pkgdesc="Yet another LaTeX filter"
-url="https://github.com/matze-dd/YaLafi"
-depends=('python3' 'languagetool')
-makedepends=('python-setuptools')
+url="https://github.com/torik42/YaLafi"
+depends=('python' 'languagetool')
+makedepends=('python-pyproject2setuppy')
license=('GPL3')
arch=('any')
source=(
- "https://github.com/matze-dd/YaLafi/archive/$pkgver.zip"
+ "https://github.com/torik42/YaLafi/archive/$pkgver.zip"
"ltdirectory.patch"
)
-sha256sums=('7e2985c11f6001d586e09a5cf2838479fe12600cfff315933941952110c67259'
+sha256sums=('0062175c40659eb16beff26cb934f073c87f6e6e5f56657b713eb401ec6973cc'
'ff59913ed6c4cc63dcf47f9604d5a096bd30e152f14e36ec53fa1e37793e5c10')
prepare() {
- cd "$srcdir/YaLafi-$pkgver"
+ cd YaLafi-$pkgver
patch -p1 < "$srcdir/ltdirectory.patch"
}
build() {
- cd "$srcdir/YaLafi-$pkgver"
- python setup.py build
+ cd YaLafi-$pkgver
+ python -m pyproject2setuppy.main build
}
package() {
- cd "$srcdir/YaLafi-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1
+ cd YaLafi-$pkgver
+ python -m pyproject2setuppy.main install --root="$pkgdir" --optimize=1
}