summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMoetaYuko2023-02-05 16:03:48 +0800
committerMoetaYuko2023-02-05 16:03:48 +0800
commit3f39166ecd35bf5e2adf27913a69901edc032cfd (patch)
tree3b824027d3b3665697f48ac512ab136e12fc5561
parent1dbd80d8e10d022c3ff18969c5d8254f00e4fe17 (diff)
downloadaur-3f39166ecd35bf5e2adf27913a69901edc032cfd.tar.gz
Deprecate pyproject2setuppy
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 31364530c213..3b12d033d5c0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = python-yalafi
pkgdesc = Yet another LaTeX filter
pkgver = 1.4.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/torik42/YaLafi
arch = any
license = GPL3
- makedepends = python-pyproject2setuppy
+ makedepends = python-build
+ makedepends = python-installer
depends = python
depends = languagetool
source = https://github.com/torik42/YaLafi/archive/1.4.0.zip
diff --git a/PKGBUILD b/PKGBUILD
index 2d7dd0d42d1c..76d897bf949d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,11 +3,11 @@
pkgname=python-yalafi
pkgver=1.4.0
-pkgrel=1
+pkgrel=2
pkgdesc="Yet another LaTeX filter"
url="https://github.com/torik42/YaLafi"
depends=('python' 'languagetool')
-makedepends=('python-pyproject2setuppy')
+makedepends=('python-build' 'python-installer')
license=('GPL3')
arch=('any')
source=(
@@ -24,10 +24,10 @@ prepare() {
build() {
cd YaLafi-$pkgver
- python -m pyproject2setuppy.main build
+ python -m build --wheel --no-isolation
}
package() {
cd YaLafi-$pkgver
- python -m pyproject2setuppy.main install --root="$pkgdir" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
}