summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoakim Repomaa2020-07-02 20:11:43 +0200
committerJoakim Repomaa2020-07-02 20:11:43 +0200
commit611d72524c8b201228c7bf083d84c469e8886ff9 (patch)
tree193409ddb472bf0fe42b2242c2512479ecf47699
downloadaur-611d72524c8b201228c7bf083d84c469e8886ff9.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e9386f424154
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = yalafi
+ pkgdesc = Yet another LaTeX filter
+ pkgver = 1.1.2
+ pkgrel = 1
+ url = https://github.com/matze-dd/YaLafi
+ arch = any
+ license = GPL3
+ makedepends = python-setuptools
+ depends = python3
+ source = https://files.pythonhosted.org/packages/0f/57/57827ab252b49616253bb007e823b810005a9a4873b8c0ff0f70ef1954d7/yalafi-1.1.2.tar.gz
+ md5sums = ca429ef24e46735d3db67583cfa1a79a
+
+pkgname = yalafi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..81099c75a701
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Automatically generated by pip2arch on 2020-07-02
+# Maintainer: Joakim Repomaa <aur@j.repomaa.com>
+
+pkgname=yalafi
+pkgver=1.1.2
+pkgrel=1
+pkgdesc="Yet another LaTeX filter"
+url="https://github.com/matze-dd/YaLafi"
+depends=('python3' )
+makedepends=('python-setuptools')
+license=('GPL3')
+arch=('any')
+source=('https://files.pythonhosted.org/packages/0f/57/57827ab252b49616253bb007e823b810005a9a4873b8c0ff0f70ef1954d7/yalafi-1.1.2.tar.gz')
+md5sums=('ca429ef24e46735d3db67583cfa1a79a')
+
+build() {
+ cd $srcdir/yalafi-1.1.2
+ python setup.py build
+}
+
+package() {
+ cd $srcdir/yalafi-1.1.2
+ python setup.py install --root="$pkgdir" --optimize=1
+}