summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Botting2023-07-03 08:50:44 +1000
committerAndy Botting2023-07-03 08:50:44 +1000
commitc7a984d407e9ee0952d8f48a8755fc4aabb69604 (patch)
tree7738aca864882385803fc267becfd7b7ff4c11e8
parent911d087bc8841395b8adf2bf5ef845e7e7f6bac9 (diff)
downloadaur-c7a984d407e9ee0952d8f48a8755fc4aabb69604.tar.gz
Update to v2.0.0-3
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d8a6b2f771b0..84d3c79e2823 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-yaql
pkgdesc = YAQL - Yet Another Query Language
pkgver = 2.0.0
- pkgrel = 2
+ pkgrel = 3
url = https://yaql.readthedocs.io
arch = any
license = Apache
diff --git a/PKGBUILD b/PKGBUILD
index 791064a738bc..d1671b054011 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=python-yaql
pkgver=2.0.0
-pkgrel=2
+pkgrel=3
pkgdesc='YAQL - Yet Another Query Language'
arch=('any')
url='https://yaql.readthedocs.io'
@@ -16,19 +16,19 @@ sha512sums=('75371b535067aac766302b74a8633230a48d2a0791e3d360e97f7d09175cccddb14
export PBR_VERSION=$pkgver
build() {
- cd yaql-$pkgver
+ cd yaql
python setup.py build
}
check() {
- cd yaql-$pkgver
+ cd yaql
# Fix test function name for Python 3
sed -i 's/assertItemsEqual/assertCountEqual/g' yaql/tests/*.py
stestr run --test-path ./yaql/tests
}
package() {
- cd yaql-$pkgver
+ cd yaql
python setup.py install --root="$pkgdir" --optimize=1
}