summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanilo J. S. Bellini2018-08-30 15:42:26 -0300
committerDanilo J. S. Bellini2018-08-30 15:47:04 -0300
commit69dc11834c5f1c0b9145848e8a3f129c9cf512eb (patch)
tree356c06d7ce8d22b799ab13609eede40eb41fdbd5
downloadaur-69dc11834c5f1c0b9145848e8a3f129c9cf512eb.tar.gz
v0.8
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD27
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..59c169eee4e0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-yellowbrick
+ pkgdesc = A suite of visual analysis and diagnostic tools for machine learning
+ pkgver = 0.8
+ pkgrel = 1
+ url = http://www.scikit-yb.org
+ arch = any
+ license = Apache
+ makedepends = python-setuptools
+ depends = python-numpy
+ depends = python-scipy
+ depends = python-matplotlib
+ depends = python-scikit-learn
+ depends = python-cycler
+ source = https://files.pythonhosted.org/packages/3f/c0/277a7720218200ae2720f94677ea898771a55298f41e5080d3e6923f4412/yellowbrick-0.8.tar.gz
+ sha256sums = 67cb9dde35fa36c8a4d700ad04b8f7478aece5e236c6785b4383d3cebe0b7e78
+
+pkgname = python-yellowbrick
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..597ea79f89a4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Danilo J. S. Bellini <danilo dot bellini at gmail dot com>
+_name=yellowbrick
+pkgbase=python-yellowbrick
+pkgname=('python-yellowbrick')
+pkgver=0.8
+pkgrel=1
+pkgdesc="A suite of visual analysis and diagnostic tools for machine learning"
+arch=('any')
+url='http://www.scikit-yb.org'
+license=('Apache')
+makedepends=('python-setuptools')
+depends=('python-numpy' 'python-scipy' 'python-matplotlib'
+ 'python-scikit-learn' 'python-cycler')
+_pypi='https://files.pythonhosted.org/packages'
+_path='3f/c0/277a7720218200ae2720f94677ea898771a55298f41e5080d3e6923f4412'
+source=("$_pypi/$_path/$_name-$pkgver.tar.gz")
+sha256sums=('67cb9dde35fa36c8a4d700ad04b8f7478aece5e236c6785b4383d3cebe0b7e78')
+
+prepare() {
+ cd "$srcdir/$_name-$pkgver"
+ rm -rf tests
+}
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}