summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-10-29 13:13:38 -0600
committerMark Wagie2021-10-29 13:13:38 -0600
commit4efbcc1a744f0cb1082ccbf56748a5a88081d111 (patch)
tree34b80fb5e38addad9c47ca3cdbd820654b03ff49
parent7a85b6d819cee2b04854891ecdc0c83c9352b94b (diff)
downloadaur-4efbcc1a744f0cb1082ccbf56748a5a88081d111.tar.gz
correct dependencies
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD29
3 files changed, 25 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 028897278e69..026fb95754f0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,15 @@
pkgbase = python-yolk3k
pkgdesc = Command-line tool for querying PyPI and Python packages installed on your system (with Python 3 support)
pkgver = 0.9
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/myint/yolk
arch = any
- license = BSD-3-Clause
- makedepends = python-setuptools
- depends = python
- optdepends = python-paste
- optdepends = rstcheck
+ license = BSD
+ depends = python-setuptools
+ optdepends = rstcheck: Check invalid reStructuredText in descriptions on PyPI
provides = python-yolk
conflicts = python-yolk
source = https://pypi.org/packages/source/y/yolk3k/yolk3k-0.9.tar.gz
sha256sums = cf8731dd0a9f7ef50b5dc253fe0174383e3fed295a653672aa918c059eef86ae
pkgname = python-yolk3k
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4dab8d6386e3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index 892d3911fefd..46ea68d76e0a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,37 +2,36 @@
pkgname=python-yolk3k
_name=${pkgname#python-}
pkgver=0.9
-pkgrel=1
+pkgrel=2
pkgdesc="Command-line tool for querying PyPI and Python packages installed on your system
(with Python 3 support)"
arch=('any')
url="https://github.com/myint/yolk"
-license=('BSD-3-Clause')
-depends=('python')
-makedepends=('python-setuptools')
+license=('BSD')
+depends=('python-setuptools')
#checkdepends=('python-pycodestyle' 'rstcheck')
-optdepends=('python-paste' 'rstcheck')
+optdepends=('rstcheck: Check invalid reStructuredText in descriptions on PyPI')
provides=("${pkgname%3k}")
conflicts=("${pkgname%3k}")
source=("https://pypi.org/packages/source/${_name:0:1}/$_name/$_name-$pkgver.tar.gz")
sha256sums=('cf8731dd0a9f7ef50b5dc253fe0174383e3fed295a653672aa918c059eef86ae')
build() {
- cd "$_name-$pkgver"
- python setup.py build
+ cd "$_name-$pkgver"
+ python setup.py build
}
#check() {
-# cd "$_name-$pkgver"
-# pycodestyle --ignore=E402 yolk setup.py
-# python setup.py --long-description | rstcheck -
-# check-manifest
-# ./check_readme.bash
+# cd "$_name-$pkgver"
+# pycodestyle --ignore=E402 yolk setup.py
+# python setup.py --long-description | rstcheck -
+# check-manifest
+# ./check_readme.bash
#}
package() {
- cd "$_name-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ cd "$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
- install -Dm644 COPYING -t "$pkgdir/usr/share/licenses/$pkgname"
+ install -Dm644 COPYING -t "$pkgdir/usr/share/licenses/$pkgname"
}