summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryochananmarqos2020-01-18 09:36:40 -0700
committeryochananmarqos2020-01-18 09:36:40 -0700
commitdc3a79c675f9221a793afac9c1e3275bb2f7abc8 (patch)
tree076eacb5cd36541d475484b33892224ea3ac7ec2
downloadaur-dc3a79c675f9221a793afac9c1e3275bb2f7abc8.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD38
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..af5eb77d05c9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-yolk3k
+ pkgdesc = Command-line tool for querying PyPI and Python packages installed on your system (with Python 3 support)
+ pkgver = 0.9
+ pkgrel = 1
+ url = https://github.com/myint/yolk
+ arch = any
+ license = BSD-3-Clause
+ makedepends = python-setuptools
+ depends = python
+ optdepends = python-paste
+ optdepends = rstcheck
+ provides = python-yolk
+ conflicts = python-yolk
+ source = https://files.pythonhosted.org/packages/source/y/yolk3k/yolk3k-0.9.tar.gz
+ sha256sums = cf8731dd0a9f7ef50b5dc253fe0174383e3fed295a653672aa918c059eef86ae
+
+pkgname = python-yolk3k
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..353afccdf1e4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+pkgname=python-yolk3k
+_name=${pkgname#python-}
+pkgver=0.9
+pkgrel=1
+pkgdesc="Command-line tool for querying PyPI and Python packages installed on your system
+ (with Python 3 support)"
+arch=('any')
+url="https://github.com/myint/yolk"
+license=('BSD-3-Clause')
+depends=('python')
+makedepends=('python-setuptools')
+#checkdepends=('python-pycodestyle')
+optdepends=('python-paste' 'rstcheck')
+provides=("${pkgname%3k}")
+conflicts=("${pkgname%3k}")
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('cf8731dd0a9f7ef50b5dc253fe0174383e3fed295a653672aa918c059eef86ae')
+
+build() {
+ cd "$_name-$pkgver"
+ python setup.py build
+}
+
+#check() {
+# cd "$_name-$pkgver"
+# pycodestyle --ignore=E402 yolk setup.py
+# python setup.py --long-description | rstcheck -
+# check-manifest
+# ./check_readme.bash
+#}
+
+package() {
+ cd "$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+
+ install -Dm644 COPYING -t "$pkgdir/usr/share/licenses/$pkgname"
+}