summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDeepjyoti Barman2020-11-19 20:39:03 +0530
committerDeepjyoti Barman2020-11-19 20:39:03 +0530
commit93ec1e8c0c26fd5cb1a15c21af8fe5577d070783 (patch)
treece6037de5080580cd317ea6b5c984445756bf840
parentd1997732774372dca2b6d3a44559d6886318027d (diff)
downloadaur-93ec1e8c0c26fd5cb1a15c21af8fe5577d070783.tar.gz
Update the version and the way it is generated
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3d1bd9740487..6c11370cf6f4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-youtube-search-git
pkgdesc = Perform YouTube video searches without the API
- pkgver = 1.1.0
- pkgrel = 0
+ pkgver = 1.1.1.r4.d199773
+ pkgrel = 1
url = https://github.com/joetats/youtube_search
arch = any
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 9cb6e7c63665..1aea722e6695 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,11 +2,13 @@
pkgname=python-youtube-search-git
pkgver() {
- cd "$pkgname"
- printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "youtube_search-master"
+ printf '%s.r%s.%s' \
+ "$(grep version= setup.py | sed 's/^\s*version="\(.*\)".*/\1/')" \
+ "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-pkgver=1.1.0
-pkgrel=0
+pkgver=1.1.1.r4.d199773
+pkgrel=1
pkgdesc="Perform YouTube video searches without the API"
arch=("any")