summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Fanninger2016-07-21 21:37:10 +0200
committerThomas Fanninger2016-07-21 21:37:10 +0200
commit64e0ba74cf32ea44a308477341ebb7140714ddc9 (patch)
treea3391be6664cfcecc8984c65e1d84a1f3d411eca
downloadaur-64e0ba74cf32ea44a308477341ebb7140714ddc9.tar.gz
Initial release
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD23
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cd372d19d33f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Thu Jul 21 19:37:00 UTC 2016
+pkgbase = python-yowsup
+ pkgdesc = The open source cross platform Whatsapp library powering Wazapp
+ pkgver = 2.5.0
+ pkgrel = 1
+ url = https://github.com/tgalal/yowsup
+ arch = any
+ license = GPL
+ makedepends = python-setuptools
+ depends = python
+ depends = python-dateutil
+ depends = python-argparse
+ depends = python-axolotl
+ depends = python-pillow
+ conflicts = yowsup-client-git
+ conflicts = python-yowsup-git
+ source = python-yowsup::https://github.com/tgalal/yowsup/archive/v2.5.0.tar.gz
+ sha512sums = SKIP
+
+pkgname = python-yowsup
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2696d0bfc9f1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Thomas Fanninger <thomas AT fanninger DOT at>
+# Contributor: Mohammed Yaseen Mowzer <moyamodehacker@gmail.com>
+# Contributor: Hugo Osvaldo Barrera <hugo@barrera.io>
+# Contributor: Jonas Heinrich <onny@project-insanity.org>
+
+pkgname='python-yowsup'
+pkgver=2.5.0
+pkgrel=1
+pkgdesc="The open source cross platform Whatsapp library powering Wazapp"
+url="https://github.com/tgalal/yowsup"
+arch=('any')
+license=('GPL')
+depends=('python' 'python-dateutil' 'python-argparse' 'python-axolotl' 'python-pillow')
+makedepends=('python-setuptools')
+provide=('python-yowsup')
+conflicts=('yowsup-client-git' 'python-yowsup-git')
+source=("${pkgname}::https://github.com/tgalal/yowsup/archive/v${pkgver}.tar.gz")
+sha512sums=('SKIP')
+
+package() {
+ cd "${srcdir}/yowsup-${pkgver}"
+ python setup.py install --root="$pkgdir/"
+} \ No newline at end of file