summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCorentin Cadiou2023-06-06 09:49:59 +0200
committerCorentin Cadiou2023-06-06 09:49:59 +0200
commit19ff06983a254657187735fe481eef05cdeaa522 (patch)
tree1a41f6ec4cdd7af5d30f16740fb8f22714abc176
parentd4605e61967821239a56f7eac336fe0ad4d3cca2 (diff)
downloadaur-19ff06983a254657187735fe481eef05cdeaa522.tar.gz
Update deps
-rwxr-xr-x.SRCINFO17
-rwxr-xr-xPKGBUILD24
2 files changed, 34 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 53057cf9c1f0..553a819d7991 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,26 @@
pkgbase = python-yt
pkgdesc = A community-developed analysis and visualization toolkit for volumetric data.
pkgver = 4.2.0
- pkgrel = 1
+ pkgrel = 2
url = http://yt-project.org
arch = any
license = BSD
makedepends = cython
- depends = python-numpy
+ makedepends = python-setuptools
+ makedepends = python-wheel
+ makedepends = python-ewah-bool-utils
+ makedepends = python-oldest-supported-numpy
+ depends = python-cmyt
+ depends = python-ewah-bool-utils
depends = python-matplotlib
+ depends = python-more-itertools
+ depends = python-numpy
+ depends = python-pillow
depends = python-sympy
- depends = python-unyt
- depends = python-cmyt
+ depends = python-tomli-w
depends = python-tqdm
+ depends = python-typing-extensions
+ depends = python-unyt
optdepends = jupyterlab: interactive analysis
optdepends = openmp: multithred support
optdepends = python-astropy: reading FITS files
diff --git a/PKGBUILD b/PKGBUILD
index 34bb0b2c3c11..8b50c41d0c29 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,31 @@
pkgname=python-yt
_module_name=yt
pkgver=4.2.0
-pkgrel=1
+pkgrel=2
pkgdesc="A community-developed analysis and visualization toolkit for volumetric data."
arch=(any)
url="http://yt-project.org"
license=('BSD')
-depends=('python-numpy' 'python-matplotlib' 'python-sympy' 'python-unyt' 'python-cmyt' 'python-tqdm')
-makedepends=('cython')
+depends=(
+ 'python-cmyt'
+ 'python-ewah-bool-utils'
+ 'python-matplotlib'
+ 'python-more-itertools'
+ 'python-numpy'
+ 'python-pillow'
+ 'python-sympy'
+ 'python-tomli-w'
+ 'python-tqdm'
+ 'python-typing-extensions'
+ 'python-unyt'
+)
+makedepends=(
+ 'cython'
+ 'python-setuptools'
+ 'python-wheel'
+ 'python-ewah-bool-utils'
+ 'python-oldest-supported-numpy'
+)
optdepends=(
'jupyterlab: interactive analysis'
'openmp: multithred support'