summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Cholasta2015-12-11 23:20:53 +0100
committerJan Cholasta2015-12-11 23:20:53 +0100
commit0b5b70be79f197b6d3d24b9b9ddaa91f9a941d3a (patch)
treeacd05bfd89e7c5fbe38bc53412c00bcf952d6df3
downloadaur-0b5b70be79f197b6d3d24b9b9ddaa91f9a941d3a.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD34
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..362645f0bf6a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python2-yubico
+ pkgdesc = Pure-python library for interacting with Yubikeys
+ pkgver = 1.3.1
+ pkgrel = 1
+ url = https://github.com/Yubico/python-yubico
+ arch = any
+ license = GPL
+ checkdepends = python2-nose
+ makedepends = python2-setuptools
+ depends = python2-pyusb>=1.0.0
+ source = https://github.com/Yubico/python-yubico/archive/python-yubico-1.3.1.tar.gz
+ sha256sums = 80a51a2eccde17724b7da3b04558e81ec49f94cc29dc1c13ab51a594d50a6b4a
+
+pkgname = python2-yubico
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c1a848b39cb9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/*.tar.gz
+/*.tar.xz
+/pkg/
+/src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ee46e713ab9f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Jan Cholasta <grubber at grubber cz>
+# Based on Fedora python-yubico.spec
+
+pkgname=python2-yubico
+pkgver=1.3.1
+pkgrel=1
+pkgdesc="Pure-python library for interacting with Yubikeys"
+arch=('any')
+url="https://github.com/Yubico/python-yubico"
+license=('GPL')
+depends=('python2-pyusb>=1.0.0')
+makedepends=('python2-setuptools')
+checkdepends=('python2-nose')
+source=("https://github.com/Yubico/python-yubico/archive/python-yubico-$pkgver.tar.gz")
+sha256sums=('80a51a2eccde17724b7da3b04558e81ec49f94cc29dc1c13ab51a594d50a6b4a')
+
+build() {
+ cd python-yubico-python-yubico-$pkgver
+
+ python2 setup.py build
+}
+
+check() {
+ cd python-yubico-python-yubico-$pkgver
+
+ # Exclude tests that require a physical yubikey attached.
+ nosetests2 -e test_challenge_response -e test_serial -e test_status
+}
+
+package() {
+ cd python-yubico-python-yubico-$pkgver
+
+ python2 setup.py install -O1 --skip-build --root "$pkgdir"
+}