summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbrent s2016-11-10 23:27:25 -0500
committerbrent s2016-11-10 23:41:25 -0500
commit47c8096434a5681354198118dfec27403f177d5c (patch)
tree1c0851103fb2993b2d4d71186ea8fe36bbe296e3
downloadaur-47c8096434a5681354198118dfec27403f177d5c.tar.gz
initial commit; setting up .gitignores and skeleton PKGBUILD
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore18
-rw-r--r--PKGBUILD30
-rw-r--r--ZConfig-3.1.0.tar.gz.sigbin0 -> 543 bytes
4 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..76fcacd9f385
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Fri Nov 11 04:41:10 UTC 2016
+pkgbase = python-zconfig
+ pkgdesc = Structured configuration library for python3
+ pkgver = 3.1.0
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/ZConfig
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = python
+ provides = python-zconfig
+ source = http://pypi.python.org/packages/source/Z/ZConfig/ZConfig-3.1.0.tar.gz
+ source = ZConfig-3.1.0.tar.gz.sig
+ sha512sums = 797be70d29f97104318cd53f3e61a02a21d5c356ee0a09ef77cdb113445b404bf6a9c089dea9ded6645b663c7f54ea2859b29602c88b24f573ea1b70422250c1
+ sha512sums = SKIP
+
+pkgname = python-zconfig
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e16177da2907
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,18 @@
+*/
+.*.swp
+*.pkg.tar.xz
+src/
+pkg/
+*.tar
+*.tar.bz2
+*.tar.xz
+*.tar.gz
+*.tgz
+*.txz
+*.tbz
+*.tbz2
+*.zip
+*.run
+*.7z
+*.rar
+*.deb
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..12456430cc68
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: brent s. <bts[at]square-r00t[dot]net>
+validpgpkeys=('748231EBCBD808A14F5E85D28C004C2F93481F6B')
+# Bug reports can be filed at https://bugs.square-r00t.net/index.php?project=3
+# News updates for packages can be followed at https://devblog.square-r00t.net
+pkgname=python-zconfig
+pkgver=3.1.0
+pkgrel=1
+pkgdesc="Structured configuration library for python3"
+arch=('i686' 'x86_64')
+url="https://pypi.python.org/pypi/ZConfig"
+license=('GPL')
+depends=('python')
+_pkgname=ZConfig
+provides=("python-zconfig")
+#conflicts=("python-zconfig")
+install=
+changelog=
+noextract=()
+source=("http://pypi.python.org/packages/source/Z/${_pkgname}/${_pkgname}-${pkgver}.tar.gz"
+ "${_pkgname}-${pkgver}.tar.gz.sig")
+sha512sums=('797be70d29f97104318cd53f3e61a02a21d5c356ee0a09ef77cdb113445b404bf6a9c089dea9ded6645b663c7f54ea2859b29602c88b24f573ea1b70422250c1'
+ 'SKIP')
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python3 setup.py build || return 1
+}
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python3 setup.py install --root="${pkgdir}" --optimize=1 || return 1
+}
diff --git a/ZConfig-3.1.0.tar.gz.sig b/ZConfig-3.1.0.tar.gz.sig
new file mode 100644
index 000000000000..f48fa48722bd
--- /dev/null
+++ b/ZConfig-3.1.0.tar.gz.sig
Binary files differ