summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabriel Rauter2022-04-02 12:27:37 +0200
committerGabriel Rauter2022-04-02 12:31:46 +0200
commit1e042dd7f0251538c3a7a862bf532b0d3779ce41 (patch)
treea4c5006916fd57f45ae729023f711778abdc7c13
parent3ac8594ffadd5b844f5261f873fe19296c12fea9 (diff)
downloadaur-1e042dd7f0251538c3a7a862bf532b0d3779ce41.tar.gz
Use release tarball
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 022e99eedf31..12e068cdbf21 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -12,7 +12,7 @@ pkgbase = python-zigpy-deconz
depends = python
depends = python-zigpy
depends = python-pyserial-asyncio
- source = python-zigpy-deconz::git+https://github.com/zigpy/zigpy-deconz#tag=0.14.0
- sha512sums = SKIP
+ source = zigpy-deconz-0.14.0.tar.gz::https://github.com/zigpy/zigpy-deconz/archive/0.14.0.tar.gz
+ sha512sums = 8552f3db53a47f280efcb6d297d432ddbfb30f4524fb46978ee20d1cb4612d69a3003ec96223c681c33253661c93de17595a3ac9f866a75b057c44b9fb524126
pkgname = python-zigpy-deconz
diff --git a/PKGBUILD b/PKGBUILD
index c6572b1f5d7b..1e4834e2e993 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,20 +19,20 @@ makedepends=(
'python-installer'
)
checkdepends=('python-pytest-asyncio')
-source=($pkgname::"git+https://github.com/zigpy/zigpy-deconz#tag=$pkgver")
-sha512sums=('SKIP')
+source=("$_pkgname-$pkgver.tar.gz::https://github.com/zigpy/zigpy-deconz/archive/$pkgver.tar.gz")
+sha512sums=('8552f3db53a47f280efcb6d297d432ddbfb30f4524fb46978ee20d1cb4612d69a3003ec96223c681c33253661c93de17595a3ac9f866a75b057c44b9fb524126')
build() {
- cd $pkgname
+ cd $_pkgname-$pkgver
python -m build --wheel --no-isolation
}
check() {
- cd $pkgname
+ cd $_pkgname-$pkgver
pytest
}
package() {
- cd $pkgname
+ cd $_pkgname-$pkgver
python -m installer --destdir="$pkgdir" dist/*.whl
}