summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabriel Rauter2022-04-02 12:23:45 +0200
committerGabriel Rauter2022-04-02 12:23:45 +0200
commit3ac8594ffadd5b844f5261f873fe19296c12fea9 (patch)
tree7ecebe48ab824140321d8d754d2803b2d65ec341
parentdc198935d487c4a221b3952c90f06a39ac570718 (diff)
downloadaur-3ac8594ffadd5b844f5261f873fe19296c12fea9.tar.gz
Update to PEP 517
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD21
2 files changed, 14 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c35ef86d6096..022e99eedf31 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,6 +7,8 @@ pkgbase = python-zigpy-deconz
license = GPL3
checkdepends = python-pytest-asyncio
makedepends = git
+ makedepends = python-build
+ makedepends = python-installer
depends = python
depends = python-zigpy
depends = python-pyserial-asyncio
diff --git a/PKGBUILD b/PKGBUILD
index 5f12f5385be4..c6572b1f5d7b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,20 +8,23 @@ pkgdesc='Zigpy support for deCONZ based Zigbee radio devices.'
url='https://github.com/zigpy/zigpy-deconz'
arch=('any')
license=('GPL3')
-depends=('python' 'python-zigpy' 'python-pyserial-asyncio')
-makedepends=('git')
+depends=(
+ 'python'
+ 'python-zigpy'
+ 'python-pyserial-asyncio'
+)
+makedepends=(
+ 'git'
+ 'python-build'
+ 'python-installer'
+)
checkdepends=('python-pytest-asyncio')
source=($pkgname::"git+https://github.com/zigpy/zigpy-deconz#tag=$pkgver")
sha512sums=('SKIP')
-pkgver() {
- cd $pkgname
- git describe --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
-}
-
build() {
cd $pkgname
- python setup.py build
+ python -m build --wheel --no-isolation
}
check() {
@@ -31,5 +34,5 @@ check() {
package() {
cd $pkgname
- python setup.py install --root="$pkgdir" -O1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
}