summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKaizhao Zhang2019-01-14 12:26:16 +0800
committerKaizhao Zhang2019-01-14 12:26:16 +0800
commit184391ab657b5de6f3df4223810715bd7f142b8a (patch)
treee2ab791a4a0ec116fd35ce62de662433fdf7f1d2
parent3b56e39c0d67c5bdcb47bf4c5c6d930f375eff91 (diff)
downloadaur-184391ab657b5de6f3df4223810715bd7f142b8a.tar.gz
Packaging without tests.py file
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD9
-rw-r--r--without-tests.patch11
4 files changed, 25 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a633fbbfe51d..3857bf4a1c22 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-zimports
pkgdesc = yet another import fixing tool
pkgver = 0.1.3
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/sqlalchemyorg/zimports
arch = any
license = BSD
@@ -11,7 +11,9 @@ pkgbase = python-zimports
depends = python-flake8-import-order
options = !emptydirs
source = https://files.pythonhosted.org/packages/17/9e/ff7223a7ead8c064435b6200267b1abb5b34c71822ad2ea6d4eaaed8862e/zimports-0.1.3.tar.gz
+ source = without-tests.patch
sha256sums = 1297e0ecfc80dfe746cef3142ae9614eab1bf56ef75176fdea75a0915ab073e7
+ sha256sums = a174aa9b52935d37febe6f6d6a358cf9773c7adc7aa771cb49dc32bf2a699fd9
pkgname = python-zimports
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..924dfb95c209
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/
+src/
+*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
index 9f63a3f20b56..15f0070ead97 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ _srcname=zimports
pkgname=python-zimports
pkgver=0.1.3
-pkgrel=1
+pkgrel=2
pkgdesc="yet another import fixing tool"
arch=('any')
url="https://github.com/sqlalchemyorg/zimports"
@@ -17,11 +17,18 @@ makedepends=('python' 'python-setuptools')
options=(!emptydirs)
source=(
"https://files.pythonhosted.org/packages/17/9e/ff7223a7ead8c064435b6200267b1abb5b34c71822ad2ea6d4eaaed8862e/zimports-${pkgver}.tar.gz"
+ 'without-tests.patch'
)
sha256sums=(
'1297e0ecfc80dfe746cef3142ae9614eab1bf56ef75176fdea75a0915ab073e7'
+ 'a174aa9b52935d37febe6f6d6a358cf9773c7adc7aa771cb49dc32bf2a699fd9'
)
+prepare() {
+ cd "${srcdir}/${_srcname}-${pkgver}"
+ patch -p0 -i ../without-tests.patch
+}
+
build() {
cd "${srcdir}/${_srcname}-${pkgver}"
python setup.py build
diff --git a/without-tests.patch b/without-tests.patch
new file mode 100644
index 000000000000..558adf23def9
--- /dev/null
+++ b/without-tests.patch
@@ -0,0 +1,11 @@
+--- setup.py.orig 2019-01-14 12:20:02.077392088 +0800
++++ setup.py 2019-01-14 12:21:09.911891740 +0800
+@@ -18,7 +18,7 @@
+ author_email='mike_mp@zzzcomputing.com',
+ url='https://github.com/sqlalchemyorg/zimports',
+ license='BSD',
+- py_modules=('zimports', 'tests'),
++ py_modules=('zimports',),
+ zip_safe=False,
+ install_requires=['pyflakes', 'flake8-import-order'],
+ tests_require=['mock'],