summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2019-02-07 13:35:25 -0500
committerGuillaume Horel2019-02-07 13:35:25 -0500
commit24b505f91fed083f78f8e5c837d37ffe2b5851f8 (patch)
tree8eb889b6bd17c4a163bc2fdd12b4352fc2847341
parent9bcb85fdf0aa10a49c7f52c70eb8477e52e1700d (diff)
downloadaur-24b505f91fed083f78f8e5c837d37ffe2b5851f8.tar.gz
make it compatible with hypothesis>=4
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
-rw-r--r--hypothesis-4.patch13
3 files changed, 26 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 39a6c9a1dd95..6729f930231c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-zstandard
pkgdesc = Python bindings to the Zstandard (zstd) compression library
pkgver = 0.10.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/indygreg/python-zstandard
arch = x86_64
license = BSD
@@ -10,7 +10,9 @@ pkgbase = python-zstandard
depends = python
optdepends = python-cffi
source = https://github.com/indygreg/python-zstandard/archive/0.10.2.tar.gz
+ source = hypothesis-4.patch
sha256sums = f684c1457f99c344f9bb5268cca49cd96fcf239b7d27acf3785390427a6d1476
+ sha256sums = e639bc7774c2ccfb145240858bd8f99af5bbadec38fe7071aea5159f18d13504
pkgname = python-zstandard
diff --git a/PKGBUILD b/PKGBUILD
index 6cd38ad4fbbb..0954ba520776 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=('python-zstandard')
_pkgname='zstandard'
pkgver='0.10.2'
-pkgrel=1
+pkgrel=2
pkgdesc="Python bindings to the Zstandard (zstd) compression library"
url="https://github.com/indygreg/python-zstandard"
depends=('python')
@@ -12,8 +12,15 @@ checkdepends=('python-hypothesis')
optdepends=('python-cffi')
license=('BSD')
arch=('x86_64')
-source=("https://github.com/indygreg/python-zstandard/archive/$pkgver.tar.gz")
-sha256sums=('f684c1457f99c344f9bb5268cca49cd96fcf239b7d27acf3785390427a6d1476')
+source=("https://github.com/indygreg/python-zstandard/archive/$pkgver.tar.gz"
+ "hypothesis-4.patch")
+sha256sums=('f684c1457f99c344f9bb5268cca49cd96fcf239b7d27acf3785390427a6d1476'
+ 'e639bc7774c2ccfb145240858bd8f99af5bbadec38fe7071aea5159f18d13504')
+
+prepare() {
+ cd "${srcdir}"
+ patch -p0 < hypothesis-4.patch
+}
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
diff --git a/hypothesis-4.patch b/hypothesis-4.patch
new file mode 100644
index 000000000000..fc5f191e0898
--- /dev/null
+++ b/hypothesis-4.patch
@@ -0,0 +1,13 @@
+diff -urN python-zstandard-0.10.2-orig/tests/common.py python-zstandard-0.10.2/tests/common.py
+--- python-zstandard-0.10.2-orig/tests/common.py 2018-11-03 16:11:40.000000000 -0400
++++ python-zstandard-0.10.2/tests/common.py 2019-02-07 13:31:23.495095114 -0500
+@@ -143,8 +143,7 @@
+ default_settings = hypothesis.settings()
+ hypothesis.settings.register_profile('default', default_settings)
+
+- ci_settings = hypothesis.settings(max_examples=2500,
+- max_iterations=2500)
++ ci_settings = hypothesis.settings(max_examples=2500)
+ hypothesis.settings.register_profile('ci', ci_settings)
+
+ hypothesis.settings.load_profile(