summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2018-12-20 14:46:28 -0500
committerGuillaume Horel2018-12-20 14:46:28 -0500
commit9bcb85fdf0aa10a49c7f52c70eb8477e52e1700d (patch)
tree2b982edf8288cda4e82714a5109195b40b1a6e74
parenta8fe0944598f8275abbf5713be57f53435995725 (diff)
downloadaur-9bcb85fdf0aa10a49c7f52c70eb8477e52e1700d.tar.gz
version bump and bugfix
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 64b6fc826242..39a6c9a1dd95 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = python-zstandard
pkgdesc = Python bindings to the Zstandard (zstd) compression library
- pkgver = 0.9.1
+ pkgver = 0.10.2
pkgrel = 1
- url = https://thriftpy.readthedocs.org/
+ url = https://github.com/indygreg/python-zstandard
arch = x86_64
license = BSD
checkdepends = python-hypothesis
makedepends = python-setuptools
depends = python
optdepends = python-cffi
- source = https://github.com/indygreg/python-zstandard/releases/download/0.9.1/python-zstandard-0.9.1.tar.gz
- sha256sums = 59c7d6f1f85cebb5124abb50d8ec281c5311e0812e18785e28b197cf1515dd3b
+ source = https://github.com/indygreg/python-zstandard/archive/0.10.2.tar.gz
+ sha256sums = f684c1457f99c344f9bb5268cca49cd96fcf239b7d27acf3785390427a6d1476
pkgname = python-zstandard
diff --git a/PKGBUILD b/PKGBUILD
index 2d9cf83de633..6cd38ad4fbbb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
pkgname=('python-zstandard')
_pkgname='zstandard'
-pkgver='0.9.1'
+pkgver='0.10.2'
pkgrel=1
pkgdesc="Python bindings to the Zstandard (zstd) compression library"
url="https://github.com/indygreg/python-zstandard"
@@ -12,22 +12,22 @@ checkdepends=('python-hypothesis')
optdepends=('python-cffi')
license=('BSD')
arch=('x86_64')
-source=("https://github.com/indygreg/python-zstandard/releases/download/$pkgver/$pkgname-$pkgver.tar.gz")
-sha256sums=('59c7d6f1f85cebb5124abb50d8ec281c5311e0812e18785e28b197cf1515dd3b')
+source=("https://github.com/indygreg/python-zstandard/archive/$pkgver.tar.gz")
+sha256sums=('f684c1457f99c344f9bb5268cca49cd96fcf239b7d27acf3785390427a6d1476')
build() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
python setup.py build_ext
}
check() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
python setup.py build_ext --inplace
python setup.py test
}
package() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}