summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2018-07-06 11:53:21 -0400
committerGuillaume Horel2018-07-06 11:53:21 -0400
commita8fe0944598f8275abbf5713be57f53435995725 (patch)
tree5eb3bedd2048f5d31bea1c3296490f8e1e065cff
downloadaur-a8fe0944598f8275abbf5713be57f53435995725.tar.gz
initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD33
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..64b6fc826242
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-zstandard
+ pkgdesc = Python bindings to the Zstandard (zstd) compression library
+ pkgver = 0.9.1
+ pkgrel = 1
+ url = https://thriftpy.readthedocs.org/
+ arch = x86_64
+ license = BSD
+ checkdepends = python-hypothesis
+ makedepends = python-setuptools
+ depends = python
+ optdepends = python-cffi
+ source = https://github.com/indygreg/python-zstandard/releases/download/0.9.1/python-zstandard-0.9.1.tar.gz
+ sha256sums = 59c7d6f1f85cebb5124abb50d8ec281c5311e0812e18785e28b197cf1515dd3b
+
+pkgname = python-zstandard
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2d9cf83de633
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
+pkgname=('python-zstandard')
+_pkgname='zstandard'
+pkgver='0.9.1'
+pkgrel=1
+pkgdesc="Python bindings to the Zstandard (zstd) compression library"
+url="https://github.com/indygreg/python-zstandard"
+depends=('python')
+makedepends=(
+ 'python-setuptools')
+checkdepends=('python-hypothesis')
+optdepends=('python-cffi')
+license=('BSD')
+arch=('x86_64')
+source=("https://github.com/indygreg/python-zstandard/releases/download/$pkgver/$pkgname-$pkgver.tar.gz")
+sha256sums=('59c7d6f1f85cebb5124abb50d8ec281c5311e0812e18785e28b197cf1515dd3b')
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py build_ext
+}
+
+check() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py build_ext --inplace
+ python setup.py test
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}