summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2019-06-12 10:03:56 -0400
committerGuillaume Horel2019-06-12 10:03:56 -0400
commitae981024c10bf1e8953acff1b96f0433b3fc66dd (patch)
tree2824294a0c2bbb8521f457f162dba66e5fef4a96
parent24b505f91fed083f78f8e5c837d37ffe2b5851f8 (diff)
downloadaur-ae981024c10bf1e8953acff1b96f0433b3fc66dd.tar.gz
version bump
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
-rw-r--r--hypothesis-4.patch13
3 files changed, 8 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6729f930231c..6e30dd689c63 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-zstandard
pkgdesc = Python bindings to the Zstandard (zstd) compression library
- pkgver = 0.10.2
- pkgrel = 2
+ pkgver = 0.11.1
+ pkgrel = 1
url = https://github.com/indygreg/python-zstandard
arch = x86_64
license = BSD
@@ -9,10 +9,8 @@ pkgbase = python-zstandard
makedepends = python-setuptools
depends = python
optdepends = python-cffi
- source = https://github.com/indygreg/python-zstandard/archive/0.10.2.tar.gz
- source = hypothesis-4.patch
- sha256sums = f684c1457f99c344f9bb5268cca49cd96fcf239b7d27acf3785390427a6d1476
- sha256sums = e639bc7774c2ccfb145240858bd8f99af5bbadec38fe7071aea5159f18d13504
+ source = https://github.com/indygreg/python-zstandard/archive/0.11.1.tar.gz
+ sha256sums = 2df90698e22f0da49cdd360438479f363e58eb8c3ac6e8bac84d831cf8e7baf4
pkgname = python-zstandard
diff --git a/PKGBUILD b/PKGBUILD
index 0954ba520776..849f2f6e42f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
pkgname=('python-zstandard')
_pkgname='zstandard'
-pkgver='0.10.2'
-pkgrel=2
+pkgver='0.11.1'
+pkgrel=1
pkgdesc="Python bindings to the Zstandard (zstd) compression library"
url="https://github.com/indygreg/python-zstandard"
depends=('python')
@@ -12,15 +12,8 @@ checkdepends=('python-hypothesis')
optdepends=('python-cffi')
license=('BSD')
arch=('x86_64')
-source=("https://github.com/indygreg/python-zstandard/archive/$pkgver.tar.gz"
- "hypothesis-4.patch")
-sha256sums=('f684c1457f99c344f9bb5268cca49cd96fcf239b7d27acf3785390427a6d1476'
- 'e639bc7774c2ccfb145240858bd8f99af5bbadec38fe7071aea5159f18d13504')
-
-prepare() {
- cd "${srcdir}"
- patch -p0 < hypothesis-4.patch
-}
+source=("https://github.com/indygreg/python-zstandard/archive/$pkgver.tar.gz")
+sha256sums=('2df90698e22f0da49cdd360438479f363e58eb8c3ac6e8bac84d831cf8e7baf4')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
diff --git a/hypothesis-4.patch b/hypothesis-4.patch
deleted file mode 100644
index fc5f191e0898..000000000000
--- a/hypothesis-4.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff -urN python-zstandard-0.10.2-orig/tests/common.py python-zstandard-0.10.2/tests/common.py
---- python-zstandard-0.10.2-orig/tests/common.py 2018-11-03 16:11:40.000000000 -0400
-+++ python-zstandard-0.10.2/tests/common.py 2019-02-07 13:31:23.495095114 -0500
-@@ -143,8 +143,7 @@
- default_settings = hypothesis.settings()
- hypothesis.settings.register_profile('default', default_settings)
-
-- ci_settings = hypothesis.settings(max_examples=2500,
-- max_iterations=2500)
-+ ci_settings = hypothesis.settings(max_examples=2500)
- hypothesis.settings.register_profile('ci', ci_settings)
-
- hypothesis.settings.load_profile(