summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authort00n2017-03-16 15:30:58 +0100
committert00n2017-03-16 15:30:58 +0100
commit2f82bcb06ee6dc77abdd3c9a0a5169f123d7c843 (patch)
treef70690adbf6c28f51c0118b0aacacae7a8dd0e92
downloadaur-2f82bcb06ee6dc77abdd3c9a0a5169f123d7c843.tar.gz
[add] initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD34
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a220deaedc69
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python0.9
+ pkgdesc = The oldest version of Python I could find
+ pkgver = 0.9
+ pkgrel = 1
+ epoch = 1
+ url = https://www.python.org
+ arch = any
+ makedepends = make
+ source = https://www.python.org/ftp/python/src/Python-0.9.1.tar.gz
+ sha256sums = 4a9cbf404dc0628eecf06bd3942f8eaf0194797192dbc54c4433ec631ecc688c
+
+pkgname = python0.9
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aa322a5beb70
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer : Antoine Carpentier
+pkgname=python0.9
+pkgver=0.9
+pkgrel=1
+epoch=1
+pkgdesc="The oldest version of Python I could find"
+arch=('any')
+url="https://www.python.org"
+license=()
+makedepends=('make')
+source=('https://www.python.org/ftp/python/src/Python-0.9.1.tar.gz')
+sha256sums=('4a9cbf404dc0628eecf06bd3942f8eaf0194797192dbc54c4433ec631ecc688c')
+CFLAGS=""
+# install=$pkgname.install
+
+prepare()
+{
+ cd python-0.9.1/src
+ sed -i "s/mv @python python//g" Makefile
+}
+
+build()
+{
+ cd python-0.9.1/src
+ make clean
+ make python
+}
+
+package()
+{
+ mkdir -p $pkgdir/usr/bin
+ install -m 775 python-0.9.1/src/python $pkgdir/usr/bin/python0.9
+}
+