summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarti Raudsepp2012-05-01 15:11:50 +0300
committerMarti Raudsepp2012-05-01 15:11:50 +0300
commit6c538efff70800a8add48f87b796a3f87e2082c5 (patch)
tree67290fea0ebc1859efdd34894cb8adc29cc967b2
downloadaur-6c538efff70800a8add48f87b796a3f87e2082c5.tar.gz
Add python15
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD41
-rw-r--r--getline.patch12
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..204307c6bb14
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python15
+ pkgdesc = Yes, an ancient version of Python, lol
+ pkgver = 1.5.2
+ pkgrel = 1
+ url = http://www.python.org/
+ arch = i686
+ arch = x86_64
+ license = PSF
+ depends = bash
+ options = !makeflags
+ source = http://www.python.org/ftp/python/src/py152.tgz
+ source = getline.patch
+ sha1sums = 2d648d07b1aa1aab32a3a24851c33715141779b9
+ sha1sums = 4a7b8064f7e6eebd398694bc7c373b700b2e5535
+
+pkgname = python15
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d9e7744ca148
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# $Id: PKGBUILD 157114 2012-04-24 00:17:20Z stephane $
+# Maintainer: Marti Raudsepp <marti@juffo.org>
+
+pkgname=python15
+pkgver=1.5.2
+pkgrel=1
+pkgdesc="Yes, an ancient version of Python, lol"
+arch=('i686' 'x86_64')
+license=('PSF')
+url="http://www.python.org/"
+depends=('bash')
+makedepends=()
+optdepends=()
+options=('!makeflags')
+source=(http://www.python.org/ftp/python/src/py152.tgz getline.patch)
+sha1sums=('2d648d07b1aa1aab32a3a24851c33715141779b9'
+ '4a7b8064f7e6eebd398694bc7c373b700b2e5535')
+
+build() {
+ cd "$srcdir/Python-$pkgver"
+
+ patch -p1 < $srcdir/getline.patch
+
+ export OPT="$CFLAGS"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/Python-$pkgver"
+ mkdir "$pkgdir/usr"
+ # Makefile doesn't understand DESTDIR
+ make INSTALL=install prefix="$pkgdir/usr" install
+
+ # Hack fix
+ rm "$pkgdir/usr/bin/python"
+ rm -r "$pkgdir/usr/man"
+
+ # Dunno why these have wrong mode... Easier to just work around :)
+ chmod 755 "$pkgdir/usr"/{bin,lib,include}
+}
diff --git a/getline.patch b/getline.patch
new file mode 100644
index 000000000000..a7449c26dd0d
--- /dev/null
+++ b/getline.patch
@@ -0,0 +1,12 @@
+--- Python-1.5.2/Objects/fileobject.c.orig 2012-05-01 14:39:04.857802025 +0300
++++ Python-1.5.2/Objects/fileobject.c 2012-05-01 14:39:29.663531501 +0300
+@@ -64,6 +64,9 @@
+
+ #include <errno.h>
+
++// Work around name conflict with newer stdio.h
++#define getline py_getline
++
+ typedef struct {
+ PyObject_HEAD
+ FILE *f_fp;