summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanilo J. S. Bellini2017-01-03 18:59:22 -0200
committerDanilo J. S. Bellini2017-01-03 18:59:22 -0200
commit2a17b38414f6870c6e5e37d048d926844566d1af (patch)
tree2124edf379ea2d43a138fffc45df6d69a7ce9a21
downloadaur-2a17b38414f6870c6e5e37d048d926844566d1af.tar.gz
v2.0.0.post1-1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e94d8057fd35
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python2-affine
+ pkgdesc = Matrices describing affine transformation of the plane (Python 2.7)
+ pkgver = 2.0.0.post1
+ pkgrel = 1
+ url = https://github.com/sgillies/affine
+ arch = any
+ license = BSD
+ makedepends = python2-setuptools
+ options = !emptydirs
+ source = https://pypi.python.org/packages/b0/3c/e1a37f1e92f27f5e32371b572201819c59d5e917d600d46df80f780cab43/affine-2.0.0.post1.tar.gz#md5=b7f4e2c86adc6575a7563c401d07f992
+ source = https://raw.githubusercontent.com/sgillies/affine/2.0.0.post1/LICENSE.txt
+ md5sums = b7f4e2c86adc6575a7563c401d07f992
+ md5sums = 75dd4e368ae6aeef7f6ab3f8e8e796a8
+
+pkgname = python2-affine
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..648e14823f68
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Danilo J. S. Bellini <danilo dot bellini at gmail dot com>
+_name=affine
+pkgname=('python2-affine')
+pkgver=2.0.0.post1
+pkgrel=1
+pkgdesc="Matrices describing affine transformation of the plane (Python 2.7)"
+arch=('any')
+url='https://github.com/sgillies/affine'
+license=('BSD')
+makedepends=('python2-setuptools')
+options=(!emptydirs)
+md5sums=('b7f4e2c86adc6575a7563c401d07f992'
+ '75dd4e368ae6aeef7f6ab3f8e8e796a8')
+_pypi='https://pypi.python.org/packages'
+_path='b0/3c/e1a37f1e92f27f5e32371b572201819c59d5e917d600d46df80f780cab43'
+source=("$_pypi/$_path/$_name-$pkgver.tar.gz#md5=$md5sums"
+ "https://raw.githubusercontent.com/sgillies/affine/$pkgver/LICENSE.txt")
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+ install -Dm644 ../LICENSE.txt \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
+}