summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Nagy2015-06-08 20:35:41 +0200
committerDaniel Nagy2015-06-08 20:35:41 +0200
commit070119b9fd9276dca7a362aecb888514fa522cf3 (patch)
treeeb5443e1d856f24f1efc15a3ee4db0d5be77fb90
downloadaur-070119b9fd9276dca7a362aecb888514fa522cf3.tar.gz
import to aur4
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD22
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ae3a5256173e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python2-akismet
+ pkgdesc = A Python interface to the Akismet anti comment-spam API.
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = http://www.voidspace.org.uk/python/modules.shtml#akismet
+ arch = any
+ license = BSD
+ depends = python2
+ source = https://pypi.python.org/packages/source/a/akismet/akismet-0.2.0.tar.gz
+ md5sums = bd4b471d88aadad00a6fd70dea97e718
+
+pkgname = python2-akismet
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c6bf9ef6fd46
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Daniel Nagy <danielnagy at gmx de>
+
+pkgname=python2-akismet
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="A Python interface to the Akismet anti comment-spam API."
+url="http://www.voidspace.org.uk/python/modules.shtml#akismet"
+depends=( 'python2' )
+license=( 'BSD' )
+arch=('any')
+source=( "https://pypi.python.org/packages/source/a/akismet/akismet-$pkgver.tar.gz")
+md5sums=('bd4b471d88aadad00a6fd70dea97e718')
+
+build() {
+ cd $srcdir/akismet-$pkgver
+ python2 setup.py build
+}
+
+package() {
+ cd $srcdir/akismet-$pkgver
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}