summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoroneup2017-11-30 23:47:55 -0500
committeroneup2017-11-30 23:47:55 -0500
commitd261acfc362824df362e3f9b9f1bb72b8728d407 (patch)
treec6592ad00521fd6365cae1a24d03c80f77a7f657
downloadaur-d261acfc362824df362e3f9b9f1bb72b8728d407.tar.gz
initial commit
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD35
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c5e1a80384cd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+pkgbase = python2-angr
+ pkgdesc = A multi-architecture binary analysis toolkit, with the ability to perform dynamic symbolic execution and various static analyses on binaries
+ pkgver = 7.7.9.21
+ pkgrel = 1
+ url = https://github.com/angr/angr
+ arch = x86_64
+ license = BSD
+ makedepends = python2-distribute
+ depends = python2
+ depends = python2-ana
+ depends = python2-archinfo>=7.7.9.14
+ depends = python2-bintrees
+ depends = python2-cachetools
+ depends = python2-capstone
+ depends = python2-cffi>=1.7.0
+ depends = python2-claripy>=7.7.9.14
+ depends = python2-cle>=7.7.9.21
+ depends = python2-cooldict
+ depends = python2-dpkt-fix
+ depends = python2-futures
+ depends = python2-mulpyplexer
+ depends = python2-networkx-1.11
+ depends = python2-progressbar
+ depends = python2-pygit
+ depends = python2-pyvex>=7.7.9.14
+ depends = python2-rpyc
+ depends = python2-unicorn
+ depends = glib2
+ source = https://pypi.python.org/packages/a7/76/837fc44460dadf1682e11d5f76b6b30ae9518b41ebcbb9b67e4019380526/angr-7.7.9.21.tar.gz
+ source = https://raw.githubusercontent.com/angr/angr/master/LICENSE
+ md5sums = ea1fac2e6aa0a77802285612039bcd65
+ md5sums = 92da168ebb0065f567f0ea48bed0f512
+
+pkgname = python2-angr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5b9e717158ec
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+#Automatically generated by pip2arch on 2017-11-21
+
+# Maintainer: oneup <oneup40 at gmail dot com>
+
+pkgname=python2-angr
+pkgver=7.7.9.21
+pkgrel=1
+pkgdesc="A multi-architecture binary analysis toolkit, with the ability to perform dynamic symbolic execution and various static analyses on binaries"
+url="https://github.com/angr/angr"
+depends=('python2' 'python2-ana' 'python2-archinfo>=7.7.9.14' 'python2-bintrees' 'python2-cachetools' 'python2-capstone' 'python2-cffi>=1.7.0' 'python2-claripy>=7.7.9.14' 'python2-cle>=7.7.9.21' 'python2-cooldict' 'python2-dpkt-fix' 'python2-futures' 'python2-mulpyplexer' 'python2-networkx-1.11' 'python2-progressbar' 'python2-pygit' 'python2-pyvex>=7.7.9.14' 'python2-rpyc' 'python2-unicorn' 'glib2')
+makedepends=('python2-distribute' )
+license=('BSD')
+arch=('x86_64')
+source=('https://pypi.python.org/packages/a7/76/837fc44460dadf1682e11d5f76b6b30ae9518b41ebcbb9b67e4019380526/angr-7.7.9.21.tar.gz'
+ 'https://raw.githubusercontent.com/angr/angr/master/LICENSE')
+md5sums=('ea1fac2e6aa0a77802285612039bcd65'
+ '92da168ebb0065f567f0ea48bed0f512')
+
+build() {
+ cd $srcdir/angr-7.7.9.21
+ for f in $(find . -name "*.py") ; do
+ #bugfix
+ sed -i 's|^#!/usr/bin/python env$|#!/usr/bin/env python|' $f
+
+ #specfic python version
+ sed -i 's|^#!/usr/bin/env python$|#!/usr/bin/env python2|' $f
+ done
+ python2 setup.py build
+}
+
+package() {
+ cd $srcdir/angr-7.7.9.21
+ python2 setup.py install --root="$pkgdir" --optimize=1
+ install -Dm644 $srcdir/LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}