summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoroneup402017-10-19 20:58:09 -0400
committeroneup402017-10-19 20:58:09 -0400
commit089040401379943832d164f02bb709072251a234 (patch)
tree104cd3eecd32a64372cb8f1e2b472146c1a28908
downloadaur-089040401379943832d164f02bb709072251a234.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e859872e9316
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-ansi
+ pkgdesc = ANSI cursor movement and graphics
+ pkgver = 0.1.3
+ pkgrel = 1
+ url = https://github.com/tehmaze/ansi
+ arch = any
+ license = MIT
+ depends = python2
+ options = !emptydirs
+ source = https://github.com/tehmaze/ansi/archive/ansi-0.1.3.tar.gz
+ md5sums = 4bf5805a69f3584638db101ff4f07ddf
+
+pkgname = python2-ansi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..526f7bbb7c98
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Based on python-ansi 0.1.3 PKGBUILD
+# Maintainer: oneup <oneup40 at gmail dot com>
+
+pkgname=python2-ansi
+_pkgname=ansi
+pkgver=0.1.3
+pkgrel=1
+pkgdesc="ANSI cursor movement and graphics"
+arch=('any')
+url="https://github.com/tehmaze/ansi"
+license=('MIT')
+depends=('python2')
+options=(!emptydirs)
+source=("https://github.com/tehmaze/$_pkgname/archive/$_pkgname-$pkgver.tar.gz")
+md5sums=('4bf5805a69f3584638db101ff4f07ddf')
+
+build() {
+ cd "$srcdir/$_pkgname-$_pkgname-$pkgver"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$_pkgname-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+ install -Dm644 LICENSE.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}