summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfelics2018-12-06 13:07:40 +0100
committerfelics2018-12-06 13:07:40 +0100
commit250a73671f5a436c73618b800c162390bda26e8f (patch)
tree7f539a47486aad4b4930f964f07fd9317e5f6b5a
downloadaur-250a73671f5a436c73618b800c162390bda26e8f.tar.gz
Initial Commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD43
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f2a89f0d04fe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python2-antlr3
+ pkgdesc = ANTLR3 runtime for Python
+ pkgver = 3.1.3
+ pkgrel = 1
+ url = http://www.antlr3.org/
+ arch = any
+ license = BSD
+ depends = antlr3
+ depends = python2
+ provides = python-antlr=3.1.3
+ source = https://www.antlr3.org/download/Python/antlr_python_runtime-3.1.3.tar.gz
+ sha256sums = e6ac1e5aaae4e2d9ead03d13142cca61447bdfa6a66c7552cb884c43e688532c
+
+pkgname = python2-antlr3
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2c00df145471
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: dreieck
+
+_pkgname=python2-antlr3
+pkgname="${_pkgname}"
+pkgdesc='ANTLR3 runtime for Python'
+pkgver=3.1.3
+pkgrel=1
+arch=('any')
+url="http://www.antlr3.org/"
+license=('BSD')
+depends=(
+ 'antlr3'
+ 'python2'
+)
+provides=("python-antlr=${pkgver}")
+source=(
+ "https://www.antlr3.org/download/Python/antlr_python_runtime-${pkgver}.tar.gz"
+)
+sha256sums=(
+ 'e6ac1e5aaae4e2d9ead03d13142cca61447bdfa6a66c7552cb884c43e688532c'
+)
+
+_cmd() {
+ # Prints out what to be run to stdout, and then executes it.
+ # The command and it's arguments is passed as argument(s).
+
+ printf '%s' '> '; cat <<< "$@"
+ "$@"
+}
+
+package() {
+ cd "${srcdir}/antlr_python_runtime-${pkgver}"
+
+ _cmd python2 setup.py install --root="${pkgdir}" --optimize=1
+
+ for _docfile in 'AUTHORS' 'PKG-INFO' 'README'; do
+ _cmd install -D -m644 "${_docfile}" "${pkgdir}/usr/share/doc/${pkgname}/${_docfile}"
+ done
+
+ _cmd install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ #install -d "${pkgdir}"/usr/share/licenses
+ #ln -s /usr/share/licenses/antlr2 "${pkgdir}"/usr/share/licenses/${pkgname}
+}