summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfelics2018-12-06 13:15:47 +0100
committerfelics2018-12-06 13:15:47 +0100
commit5a17943a24ab245169bf243c8e54365f0873f73a (patch)
tree8eb9e9f245a99ea9059b44c48b3d9d0bbebb081f
downloadaur-5a17943a24ab245169bf243c8e54365f0873f73a.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD42
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0ef1218bc97a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python2-antlr3-3.0.1
+ pkgdesc = ANTLR3 runtime for Python, version 3.0.1
+ pkgver = 3.0.1
+ pkgrel = 1
+ url = http://www.antlr3.org/
+ arch = any
+ license = BSD
+ depends = antlr3
+ depends = python2
+ provides = python-antlr3=3.0.1
+ conflicts = python2-antlr3
+ source = https://www.antlr3.org/download/Python/antlr_python_runtime-3.0.1.tar.gz
+ sha256sums = a14c76c51961802a147d7b46ff3a6b1ce8c18901fb086bf50bb41a9e1cc5b125
+
+pkgname = python2-antlr3-3.0.1
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3d30bd4a6667
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: dreieck
+
+_pkgname=python2-antlr3-3.0.1
+pkgname="${_pkgname}"
+pkgdesc='ANTLR3 runtime for Python, version 3.0.1'
+pkgver=3.0.1
+pkgrel=1
+arch=('any')
+url="http://www.antlr3.org/"
+license=('BSD')
+depends=(
+ 'antlr3'
+ 'python2'
+)
+provides=("python-antlr3=${pkgver}")
+conflicts=("python2-antlr3")
+source=(
+ "https://www.antlr3.org/download/Python/antlr_python_runtime-${pkgver}.tar.gz"
+)
+sha256sums=(
+ 'a14c76c51961802a147d7b46ff3a6b1ce8c18901fb086bf50bb41a9e1cc5b125'
+)
+
+_cmd() {
+ # Prints out what to be run to stdout, and then executes it.
+ # The command and it's arguments is passed as argument(s).
+
+ printf '%s' '> '; cat <<< "$@"
+ "$@"
+}
+
+package() {
+ cd "${srcdir}/antlr_python_runtime-${pkgver}"
+
+ _cmd python2 setup.py install --root="${pkgdir}" --optimize=1
+
+ for _docfile in 'AUTHORS' 'PKG-INFO' 'README'; do
+ _cmd install -D -m644 "${_docfile}" "${pkgdir}/usr/share/doc/${pkgname}/${_docfile}"
+ done
+
+ _cmd install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}