summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames An2019-06-25 01:07:01 -0400
committerJames An2019-06-25 01:07:01 -0400
commit487b2dffe4da86f3646db92211492dbe6b6d109d (patch)
tree18baecf0021d7d3734526c6fc658e69fdb7238a9
downloadaur-python2-argparse.tar.gz
Initial commit with working PKGBUILD based on python2-gsutil package.
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore27
-rw-r--r--PKGBUILD35
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d48d9ee481a9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-argparse
+ pkgdesc = Python2 command-line parsing library.
+ pkgver = 1.4.0
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/argparse
+ arch = any
+ license = Python
+ makedepends = python2-setuptools
+ depends = python2
+ source = https://files.pythonhosted.org/packages/source/a/argparse/argparse-1.4.0.tar.gz
+ md5sums = 08062d2ceb6596fcbc5a7e725b53746f
+
+pkgname = python2-argparse
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..43316bc3c124
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,27 @@
+# From: https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
+
+*.tar
+*.tar.*
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+# makepkg working folders
+pkg
+src
+
+#
+# Additional ignore patterns:
+#
+
+# Source files
+*.deb
+*.gem
+*.out
+*.rpm
+*.html
+
+# Ignore package source folders
+*/*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c45899adadbc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: James An <james@jamesan.ca>
+
+pkgname=python2-argparse
+_pkgname=${pkgname#python2-}
+pkgver=1.4.0
+pkgrel=1
+pkgdesc='Python2 command-line parsing library.'
+arch=('any')
+url="https://pypi.python.org/pypi/$_pkgname"
+license=('Python')
+depends=('python2')
+makedepends=('python2-setuptools')
+
+source=("https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz")
+md5sums=('08062d2ceb6596fcbc5a7e725b53746f')
+
+build() {
+ cd "$_pkgname-$pkgver"
+
+ python2 setup.py build
+}
+
+check() {
+ cd "$_pkgname-$pkgver"
+
+ python2 setup.py test
+}
+
+package() {
+ cd "$_pkgname-$pkgver"
+
+ python2 setup.py install --root="$pkgdir" --optimize=1
+ find $pkgdir -type f -exec chmod 0644 {} +
+ find $pkgdir -type d -exec chmod 0755 {} +
+}