summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOlivier Medoc2016-03-15 10:09:43 +0000
committerOlivier Medoc2016-03-15 10:09:43 +0000
commitd2c70c1425487c8b7fd11abf78209756beb418d0 (patch)
treef810bfa87aff5c6b15dd5139d074e5cedca6da0f
downloadaur-d2c70c1425487c8b7fd11abf78209756beb418d0.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rwxr-xr-xPKGBUILD25
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b61ef52dc53f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python2-artifacts
+ pkgdesc = A free, community-sourced, machine-readable knowledge base of forensic artifacts that the world can use both as an information source and within other tools.
+ pkgver = 20160114
+ pkgrel = 1
+ url = https://github.com/ForensicArtifacts/artifacts
+ arch = any
+ license = Apache
+ makedepends = python2
+ source = https://pypi.python.org/packages/source/a/artifacts/artifacts-20160114.tar.gz#md5=9db32dd9429fb0e09aa5998dfd78067c
+ md5sums = 9db32dd9429fb0e09aa5998dfd78067c
+
+pkgname = python2-artifacts
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..77b9f82fe68d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+pkgname=python2-artifacts
+_pkgcode=artifacts
+pkgver=20160114
+pkgrel=1
+pkgdesc="A free, community-sourced, machine-readable knowledge base of forensic artifacts that the world can use both as an information source and within other tools."
+url="https://github.com/ForensicArtifacts/artifacts"
+arch=('any')
+license=('Apache')
+
+makedepends=('python2')
+
+md5sum=9db32dd9429fb0e09aa5998dfd78067c
+source=(https://pypi.python.org/packages/source/a/$_pkgcode/$_pkgcode-$pkgver.tar.gz#md5=$md5sum)
+md5sums=($md5sum)
+
+build() {
+ cd $srcdir/${_pkgcode}-${pkgver}
+
+ python2 setup.py build
+}
+
+package() {
+ cd $srcdir/${_pkgcode}-${pkgver}
+ python2 setup.py install --root="${pkgdir}"
+}