summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQuan Guo2015-06-17 21:30:41 +0200
committerQuan Guo2015-06-17 21:30:41 +0200
commit52b0b5acd3998e8cfd2001e151f4df4dbfa5e0f9 (patch)
tree053ce118ef97c9ccf437137e90ce81304f89af95
downloadaur-52b0b5acd3998e8cfd2001e151f4df4dbfa5e0f9.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD41
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..872cb65713ae
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python2-astroml-git
+ pkgdesc = AstroML is a Python module for machine learning and data mining built on numpy, scipy, scikit-learn, and matplotlib.
+ pkgver = 2015.01.28.g8e1bfcb
+ pkgrel = 1
+ url = http://www.astroml.org/
+ arch = any
+ license = BSD-3-Clause
+ depends = python2-numpy
+ depends = python2-scipy
+ depends = python2-scikit-learn
+ depends = python2-matplotlib
+ conflicts = python2-astroml
+ conflicts = astroml-examples
+ source = git+https://github.com/astroML/astroML.git
+ md5sums = SKIP
+
+pkgname = python2-astroml-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..67938cc4e0b2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Quan Guo <guotsuan@gmail.com>
+
+pkgname=python2-astroml-git
+_pkgname=astroML
+pkgver=2015.01.28.g8e1bfcb
+pkgrel=1
+pkgdesc="AstroML is a Python module for machine learning and data mining built on numpy, scipy, scikit-learn, and matplotlib."
+
+url='http://www.astroml.org/'
+arch=('any')
+license=('BSD-3-Clause')
+depends=('python2-numpy' 'python2-scipy' 'python2-scikit-learn'
+ 'python2-matplotlib')
+
+source=("git+https://github.com/astroML/astroML.git")
+
+
+conflicts=('python2-astroml' 'astroml-examples')
+#provides=('astroml')
+md5sums=('SKIP')
+
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git log -1 --format="%cd.g%h" --date=short | sed 's/-/./g'
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ python2 ./setup.py install --root="${pkgdir}" --prefix=/usr
+ #python2 ./setup_addons.py install --root="${pkgdir}" --prefix=/usr
+ install -dm755 ${pkgdir}/usr/share/astroML/examples/{algorithms,datasets,learning}
+ install -D -m644 examples/algorithms/* \
+ ${pkgdir}/usr/share/astroML/examples/algorithms
+ install -D -m644 examples/datasets/* \
+ ${pkgdir}/usr/share/astroML/examples/datasets
+ install -D -m644 examples/learning/* \
+ ${pkgdir}/usr/share/astroML/examples/learning
+ install -D -m644 examples/README.rst ${pkgdir}/usr/share/astroML/examples
+
+}