summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMiguel de Val-Borro2018-02-06 11:40:19 -0500
committerMiguel de Val-Borro2018-02-06 11:40:19 -0500
commitca9d1a9517ebbebd116d50dbb8b150e40864f666 (patch)
tree7d438ef4e1f5ef256910bcf594492fe6d3cc5bff
parent03aa46a752f97e38b72612242b7eb8c96ba6f463 (diff)
downloadaur-ca9d1a9517ebbebd116d50dbb8b150e40864f666.tar.gz
patch to update astropy_helpers path
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
-rw-r--r--astropy_helpers.patch11
3 files changed, 15 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 709a28aafa8d..6c098e35e45d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python2-astropy-helpers
pkgdesc = Utilities used for building the Astropy python library for astronomy
pkgver = 2.0.3
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/astropy/astropy-helpers
arch = any
license = BSD
diff --git a/PKGBUILD b/PKGBUILD
index 9490ce108787..7bd954e0bb26 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: Miguel de Val-Borro <miguel.deval at gmail dot com>
+# Contributor: Universebenzene <universebenzene at sina dot com>
pkgname=('python2-astropy-helpers')
pkgver=2.0.3
-pkgrel=1
+pkgrel=2
pkgdesc="Utilities used for building the Astropy python library for astronomy"
arch=('any')
url="https://github.com/astropy/astropy-helpers"
@@ -12,6 +13,7 @@ md5sums=('8129ddec049865e7401d1a7e86b3a22b')
build() {
cd ${srcdir}/astropy-helpers-${pkgver}
+ patch -p1 -i ../../astropy_helpers.patch
python2 setup.py build --use-system-libraries
}
diff --git a/astropy_helpers.patch b/astropy_helpers.patch
new file mode 100644
index 000000000000..1552f615b6f8
--- /dev/null
+++ b/astropy_helpers.patch
@@ -0,0 +1,11 @@
+--- a/astropy_helpers/commands/build_sphinx.py 2017-10-12 03:56:31.000000000 +0800
++++ b/astropy_helpers/commands/build_sphinx.py 2018-02-06 21:49:54.599865388 +0800
+@@ -126,7 +126,7 @@
+ build_cmd = self.get_finalized_command('build')
+ build_cmd_path = os.path.abspath(build_cmd.build_lib)
+
+- ah_importer = pkgutil.get_importer('astropy_helpers')
++ ah_importer = pkgutil.get_importer('/usr/lib/python2.7/site-packages/astropy_helpers')
+ ah_path = os.path.abspath(ah_importer.path)
+
+ # Now generate the source for and spawn a new process that runs the